summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 11:05:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 11:05:43 +0000
commit134ec653ca1852cab19cf8731e9d65df6dcceabf (patch)
tree0af4a1ec9744a676567bba4b4b929483a705664a /debian/rules
parentAdding upstream version 4.0.3. (diff)
downloadnagios-nrpe-134ec653ca1852cab19cf8731e9d65df6dcceabf.tar.xz
nagios-nrpe-134ec653ca1852cab19cf8731e9d65df6dcceabf.zip
Adding debian version 4.0.3-1.debian/4.0.3-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8eacd6e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+
+# newer dpkg set this by default.
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
+# Enable hardening build flags
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+CFLAGS += $(CPPFLAGS)
+
+export AUTOHEADER=true
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib/nagios \
+ --libexecdir=/usr/lib/nagios/plugins \
+ --localstatedir=/var \
+ --enable-ssl \
+ --with-logdir=/var/log \
+ --with-ssl-lib=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ --with-piddir=/run/nagios
+
+override_dh_auto_build:
+ dh_auto_build -- all
+
+override_dh_auto_install: