summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:59:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:59:37 +0000
commitbb0294a65b2f929503d735a2a1e85612295a4376 (patch)
tree0491aba2d2376789ff2165f790859e1df8410c28 /debian/rules
parentAdding upstream version 3.38.2. (diff)
downloadnautilus-bb0294a65b2f929503d735a2a1e85612295a4376.tar.xz
nautilus-bb0294a65b2f929503d735a2a1e85612295a4376.zip
Adding debian version 3.38.2-1+deb11u1.debian/3.38.2-1+deb11u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules30
1 files changed, 30 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..bd725b8
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,30 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
+
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+ENABLE_SELINUX := -Dselinux=true
+else
+ENABLE_SELINUX := -Dselinux=false
+endif
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -Ddocs=true \
+ -Dextension=true \
+ -Dpackagekit=true \
+ -Dtests=all \
+ $(ENABLE_SELINUX)
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ touch $(CURDIR)/debian/.debhelper/generated/_source/home/.gtk-bookmarks
+ dbus-run-session -- xvfb-run --auto-servernum dh_auto_test
+endif
+
+override_dh_makeshlibs:
+ dh_makeshlibs -- -c4