summaryrefslogtreecommitdiffstats
path: root/extensions/audio-video-properties/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:59:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 15:59:36 +0000
commitec52555862913a23417735f9f7f5402f5230da13 (patch)
tree5e43a30d289a3daa69dddfbb060216ff6332f197 /extensions/audio-video-properties/meson.build
parentInitial commit. (diff)
downloadnautilus-ec52555862913a23417735f9f7f5402f5230da13.tar.xz
nautilus-ec52555862913a23417735f9f7f5402f5230da13.zip
Adding upstream version 3.38.2.upstream/3.38.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/audio-video-properties/meson.build')
-rw-r--r--extensions/audio-video-properties/meson.build53
1 files changed, 53 insertions, 0 deletions
diff --git a/extensions/audio-video-properties/meson.build b/extensions/audio-video-properties/meson.build
new file mode 100644
index 0000000..b67de9d
--- /dev/null
+++ b/extensions/audio-video-properties/meson.build
@@ -0,0 +1,53 @@
+resources = gnome.compile_resources(
+ 'nautilus-audio-video-properties-resources',
+ join_paths(
+ 'resources', 'nautilus-audio-video-properties.gresource.xml'
+ ),
+ source_dir: 'resources',
+ c_name: 'nautilus_audio_video_properties',
+)
+
+libm = cc.find_library('m')
+
+libtotem_properties_page_sources = files(
+ 'totem-properties-main.c',
+ 'totem-properties-view.c',
+ 'bacon-video-widget-properties.c',
+ 'totem-gst-helpers.c',
+) + resources
+
+libtotem_properties_page_deps = [
+ libm,
+ gst_tag_dep,
+ gst_pbutils_dep,
+]
+
+libtotem_properties_page = shared_module(
+ 'totem-properties-page',
+ sources: libtotem_properties_page_sources,
+ dependencies: libtotem_properties_page_deps + [
+ nautilus_extension
+ ],
+ c_args: [
+ '-DG_LOG_DOMAIN="TotemPropertiesPage"'
+ ],
+ install: true,
+ install_dir: extensiondir
+)
+
+test_properties_page_sources = files(
+ 'totem-properties-main.c',
+ 'totem-properties-view.c',
+ 'bacon-video-widget-properties.c',
+ 'totem-gst-helpers.c',
+ 'test-properties-page.c'
+) + resources
+
+executable(
+ 'test-properties-page',
+ test_properties_page_sources,
+ dependencies: libtotem_properties_page_deps + [
+ nautilus_extension
+ ],
+)
+