summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules30
1 files changed, 30 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..bd725b8
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,30 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
+
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+ENABLE_SELINUX := -Dselinux=true
+else
+ENABLE_SELINUX := -Dselinux=false
+endif
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -Ddocs=true \
+ -Dextension=true \
+ -Dpackagekit=true \
+ -Dtests=all \
+ $(ENABLE_SELINUX)
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ touch $(CURDIR)/debian/.debhelper/generated/_source/home/.gtk-bookmarks
+ dbus-run-session -- xvfb-run --auto-servernum dh_auto_test
+endif
+
+override_dh_makeshlibs:
+ dh_makeshlibs -- -c4