summaryrefslogtreecommitdiffstats
path: root/debian/patches/upstream
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 11:08:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 11:08:08 +0000
commitba729bd1d3089ba48b57ff6cab7e4ca21ccb4146 (patch)
tree156030137bdda66d88a8ae3d033ecf55d1c141da /debian/patches/upstream
parentAdding upstream version 1.29.3. (diff)
downloadnetdata-ba729bd1d3089ba48b57ff6cab7e4ca21ccb4146.tar.xz
netdata-ba729bd1d3089ba48b57ff6cab7e4ca21ccb4146.zip
Adding debian version 1.29.3-4.debian/1.29.3-4debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/upstream')
-rw-r--r--debian/patches/upstream/0001-allow-symlinks.patch15
-rw-r--r--debian/patches/upstream/0002-fix-FTCBFS.patch17
2 files changed, 32 insertions, 0 deletions
diff --git a/debian/patches/upstream/0001-allow-symlinks.patch b/debian/patches/upstream/0001-allow-symlinks.patch
new file mode 100644
index 0000000..7df915f
--- /dev/null
+++ b/debian/patches/upstream/0001-allow-symlinks.patch
@@ -0,0 +1,15 @@
+Author: Lennart Weller <lhw@ring0.de>
+Description: Remove file serve restrictions for symlinks.
+
+diff -Naurp netdata.orig/web/server/web_client.c netdata/web/server/web_client.c
+--- netdata.orig/web/server/web_client.c
++++ netdata/web/server/web_client.c
+@@ -381,7 +381,7 @@ int mysendfile(struct web_client *w, cha
+ int done = 0;
+ while(!done) {
+ // check if the file exists
+- if (lstat(webfilename, &statbuf) != 0) {
++ if (stat(webfilename, &statbuf) != 0) {
+ debug(D_WEB_CLIENT_ACCESS, "%llu: File '%s' is not found.", w->id, webfilename);
+ w->response.data->contenttype = CT_TEXT_HTML;
+ buffer_strcat(w->response.data, "File does not exist, or is not accessible: ");
diff --git a/debian/patches/upstream/0002-fix-FTCBFS.patch b/debian/patches/upstream/0002-fix-FTCBFS.patch
new file mode 100644
index 0000000..10cf18f
--- /dev/null
+++ b/debian/patches/upstream/0002-fix-FTCBFS.patch
@@ -0,0 +1,17 @@
+Author: Helmut Grohne <helmut@subdivi.de>
+Description: Fixes FTCBFS by not abusing AC_CHECK_FILE (Closes: #982523).
+
+diff -Naurp netdata.orig/configure.ac netdata/configure.ac
+--- netdata.orig/configure.ac
++++ netdata/configure.ac
+@@ -1025,8 +1025,8 @@ if test "${build_target}" = "linux" -a "
+ [#include <linux/bpf.h>]
+ )
+
+- AC_CHECK_FILE(
+- externaldeps/libbpf/libbpf.a,
++ AS_IF(
++ [test -e externaldeps/libbpf/libbpf.a],
+ [have_libbpf=yes],
+ [have_libbpf=no]
+ )