summaryrefslogtreecommitdiffstats
path: root/.gitignore
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--.gitignore210
1 files changed, 210 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..2049bf4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,210 @@
+# Secrets
+gcs-credentials.json
+
+.deps
+.libs
+.dirstamp
+.project
+.pydevproject
+
+*.o
+*.a
+config.h.in
+Makefile.in
+*~
+.*.swp
+*.old
+*.log
+*.pyc
+
+Makefile
+aclocal.m4
+autom4te.cache
+compile
+config.guess
+config.h
+config.status
+config.sub
+configure
+depcomp
+install-sh
+libtool
+ltmain.sh
+missing
+stamp-h1
+netdata.spec
+sha256sums.txt
+
+# netdata binaries
+netdata
+netdatacli
+!netdata/
+upload/
+artifacts/
+
+apps.plugin
+!apps.plugin/
+
+freeipmi.plugin
+!freeipmi.plugin/
+
+cups.plugin
+!cups.plugin/
+
+nfacct.plugin
+!nfacct.plugin/
+
+xenstat.plugin
+!xenstat.plugin/
+
+perf.plugin
+!perf.plugin/
+
+slabinfo.plugin
+!slabinfo.plugin/
+
+cgroup-network
+!cgroup-network/
+
+ebpf.plugin
+collectors/ebpf.plugin/reset_netdata_trace.sh
+!ebpf.plugin/
+
+# protoc generated files
+*.pb.cc
+*.pb.h
+
+# installation artifacts
+packaging/installer/.environment.sh
+*.tar.*
+*.run
+
+# netdata makeself downloads
+packaging/makeself/tmp/
+
+# coverity
+cov-int/
+netdata-coverity-analysis.tgz
+.coverity-scan.conf
+
+.cproject/
+.idea/
+.vscode/
+.project/
+.settings/
+README
+TODO.md
+TODO.txt
+
+web/gui/chart-info/
+web/gui/control.html
+web/gui/datasource.css
+web/gui/gadget.xml
+web/gui/index_new.html
+web/gui/version.txt
+
+# related to karma/javascript/node
+/node_modules/
+/coverage/
+
+system/netdata-lsb
+system/netdata-openrc
+system/netdata-init-d
+system/netdata.logrotate
+system/netdata.service
+system/netdata.service.*
+system/netdata-updater.service
+!system/netdata.service.in
+!system/netdata.service.*.in
+system/netdata.plist
+system/netdata-freebsd
+system/edit-config
+system/netdata.crontab
+
+daemon/anonymous-statistics.sh
+daemon/get-kubernetes-labels.sh
+
+health/notifications/alarm-notify.sh
+claim/netdata-claim.sh
+collectors/cgroups.plugin/cgroup-name.sh
+collectors/tc.plugin/tc-qos-helper.sh
+collectors/charts.d.plugin/charts.d.plugin
+collectors/node.d.plugin/node.d.plugin
+collectors/python.d.plugin/python.d.plugin
+collectors/fping.plugin/fping.plugin
+collectors/ioping.plugin/ioping.plugin
+collectors/go.d.plugin
+web/netdata-switch-dashboard.sh
+
+# installer generated files
+/netdata-uninstaller.sh
+/netdata-updater.sh
+
+# cmake files
+cmake-build-debug/
+cmake-build-release/
+CMakeCache.txt
+CMakeFiles/
+cmake_install.cmake
+.cmake
+compile_commands.json
+
+# jetbrains IDE
+.jetbrains*
+
+.DS_Store
+webcopylocal*
+
+# converted diagrams
+diagrams/*.png
+diagrams/*.svg
+diagrams/*.atxt
+diagrams/plantuml.jar
+
+# cppcheck
+cppcheck-build/
+
+venv/
+
+# debugging / profiling
+makeself/debug/
+tests/profile/benchmark-dictionary
+tests/profile/benchmark-registry
+tests/profile/test-eval
+tests/profile/benchmark-line-parsing
+tests/profile/benchmark-procfile-parser
+tests/profile/benchmark-value-pairs
+tests/profile/statsd-stress
+tests/health_mgmtapi/health-cmdapi-test.sh
+oprofile_data/
+vgcore.*
+callgrind.out.*
+gmon.out
+gmon.txt
+sitespeed-result/
+tests/acls/acl.sh
+tests/urls/request.sh
+tests/alarm_repetition/alarm.sh
+tests/template_dimension/template_dim.sh
+aclk/legacy/tests/install-fake-charts.d.sh
+
+# tests and temp files
+test-driver
+**/tests/*_testdriver
+**/tests/*_testdriver.trs
+python.d/python-modules-installer.sh
+
+# documentation generated files
+docs/generator/src
+docs/generator/build
+docs/generator/doc
+docs/generator/localization
+docs/generator/mkdocs.yml
+
+.environment.sh
+
+#CLion files
+netdata.cbp
+
+# External dependencies
+externaldeps/