summaryrefslogtreecommitdiffstats
path: root/web/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--web/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/web/Makefile.am b/web/Makefile.am
new file mode 100644
index 0000000..ccaccd7
--- /dev/null
+++ b/web/Makefile.am
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+AUTOMAKE_OPTIONS = subdir-objects
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+SUBDIRS = \
+ api \
+ gui \
+ server \
+ $(NULL)
+
+usersslconfigdir=$(configdir)/ssl
+
+# Explicitly install directories to avoid permission issues due to umask
+install-exec-local:
+ $(INSTALL) -d $(DESTDIR)$(usersslconfigdir)
+
+dist_noinst_DATA = \
+ README.md \
+ gui/confluence/README.md \
+ gui/custom/README.md \
+ $(NULL)