summaryrefslogtreecommitdiffstats
path: root/debian/changelog
blob: 05fd025de1bd351f689e25abc202334980d35d7a (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
powerline (2.8.1-4progress6u1) fuchur; urgency=medium

  * Initial upload to fuchur.
  * Updating maintainer field.
  * Updating uploaders field.
  * Updating bugs field.
  * Updating vcs fields.
  * Enabling powerline bash integration by default.
  * Setting user colors to white on green.
  * Setting hostname colors to white on darkblue.

 -- Daniel Baumann <daniel.baumann@progress-linux.org>  Sun, 07 Mar 2021 15:26:57 +0100

powerline (2.8.1-4) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Update Maintainer field with new Debian Python Team
    contact address.
  * d/control: Update Vcs-* fields with new Debian Python Team Salsa
    layout.

  [ Debian Janitor ]
  * Set upstream metadata fields: Bug-Submit.

  [ Samuel Henrique ]
  * Bump Standards-Version to 4.5.1
  * d/control: Add python3-i3ipc to Suggests and i3 to Enhances
    (closes: #976790)

 -- Samuel Henrique <samueloph@debian.org>  Tue, 08 Dec 2020 19:08:22 +0000

powerline (2.8.1-3) unstable; urgency=medium

  * d/control: Fix Vcs-* fields

 -- Samuel Henrique <samueloph@debian.org>  Sat, 11 Jul 2020 11:39:54 +0100

powerline (2.8.1-2) unstable; urgency=medium

  * The previous changelog entry said it updated the ru translation but
    the change was not there (and it closed the wrong bug), this is the
    correct entry.
  * d/po/ru.po: Update Russian translation, thanks to
    Lev Lamberov <dogsleg@debian.org> (closes: #951434)

 -- Samuel Henrique <samueloph@debian.org>  Sat, 11 Jul 2020 00:28:00 +0100

powerline (2.8.1-1) unstable; urgency=medium

  [ Debian Janitor ]
  * Set debhelper-compat version in Build-Depends.
  * Set upstream metadata fields: Bug-Database, Repository, Repository-
    Browse.

  [ Jerome Charaoui ]
  * Add ru translation (closes: #910849)

  [ Samuel Henrique ]
  * New upstream version 2.8.1 (closes: #964598)
    - Added ipython >= 7.0.0 support (closes: #953973)
    - d/changelog.upstream: Update upstream changelog for 2.8.1
  * Bump DH to 13
  * Bump Standards-Version to 4.5.0
  * Add debian/gbp.conf
  * Don't override dh_auto_test and add test build-dep python3-pexpect
  * d/control: Switch maintenance to PAPT team and add myself as an uploader
  * d/control: s/Multi-arch/Multi-Arch/
  * d/rules: Remove unused includes

 -- Samuel Henrique <samueloph@debian.org>  Fri, 10 Jul 2020 21:22:53 +0100

powerline (2.7-3) unstable; urgency=medium

  * Drop Python2, package is Python3-ready (Closes: #937313)
  * Updating to standards version 4.4.0, no other changes required.
  * Drop python-powerline-doc transitional package

 -- Jerome Charaoui <jerome@riseup.net>  Sat, 14 Sep 2019 11:47:28 -0400

powerline (2.7-2) unstable; urgency=medium

  * Adjust debian/watch
  * Update nl translation, fixes #920429
  * Add ru translation, fixes #910849
  * Add pt_BR translation, fixes #920539

 -- Jerome Charaoui <jerome@riseup.net>  Sun, 27 Jan 2019 14:23:23 -0500

powerline (2.7-1) unstable; urgency=medium

  [ Daniel Baumann ]
  * Switching debconf option to enable bash from a boolean to a multiselect in
    order to allow other programs to be enabled too in the future.
  * Updating to standards version 4.3.0, no other changes required.

  [ Jerome Charaoui ]
  * New upstream version 2.7
  * Add fr debconf translation, thanks Jean-Pierre Giraud (Closes: #906095)
  * Add nl debconf translation, thanks Frans Spiesschaert (Closes: #906943)
  * Add pt debconf translation, thanks Rui Branco (Closes: #907903)

 -- Jerome Charaoui <jerome@riseup.net>  Wed, 02 Jan 2019 12:11:35 -0500

powerline (2.6-2) unstable; urgency=medium

  [ Daniel Baumann ]
  * Install manapages into the powerline package only (Closes: #899135)
  * Automatically update fontconfig cache using dpkg trigger (Closes: #899142)
  * Update vim instructions in README.Debian (Closes: #899150)
  * Add debconf support to enable powerline for all users (Closes: #899184)
  * Set default shell theme to default_leftonly (Closes: #899153)
  * Switch to use python3 by default (Closes: #899165)
  * Include /etc/powerline as configuration directory (Closes: #899178)
  * Apply patch from Andreas Schneider to fix build with GCC-7 (Closes: #900331)
  * Rename python-powerline-doc to powerline-doc for consistency
  * Apply various updates and fixes to control, watch and copyright files
  * Update packaging to debhelper version 11
  * Update packaging to standards version 4.1.4

  [ Jerome Charaoui ]
  * Fix privacy breaches in documentation
  * Update NEWS file

 -- Jerome Charaoui <jerome@riseup.net>  Fri, 01 Jun 2018 15:32:49 -0400

powerline (2.6-1) unstable; urgency=medium

  * New upstream version 2.6
  * Ship upstream changelog from GitHub release logs
  * Bump Standards-Version to 4.0.1

 -- Jerome Charaoui <jerome@riseup.net>  Wed, 23 Aug 2017 14:53:23 -0400

powerline (2.5-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Changes dependency for powerline to python-powerline by default, as this is
    used by the installed binaries and is required.
  * Move python3-powerline to Recommends so as to allow for vim users to have
    this also installed by default, without requiring its installation on
    systems that do not want a Python 3 installation. (Closes: #839599)

 -- Iain R. Learmonth <irl@debian.org>  Tue, 24 Jan 2017 14:47:26 +0000

powerline (2.5-1) unstable; urgency=medium

  * Imported Upstream version 2.5
  * Add mention in README to use python3 where necessary
  * Depend on python3 library by default

 -- Jerome Charaoui <jerome@riseup.net>  Sat, 10 Sep 2016 13:49:36 -0400

powerline (2.4-1) unstable; urgency=medium

  * Imported Upstream version 2.4
  * Move fontconfig file to /etc/fonts/conf.avail (Closes: #814424)
  * Bump Standards-Version to 3.9.8
  * Switch Vcs-Git to https URL
  * Provide new bindings in the correct binary

 -- Jerome Charaoui <jerome@riseup.net>  Wed, 27 Apr 2016 10:39:05 -0400

powerline (2.3-1) unstable; urgency=medium

  * Imported Upstream version 2.3 (Closes: #802905)

 -- Jerome Charaoui <jerome@riseup.net>  Mon, 26 Oct 2015 16:03:47 -0400

powerline (2.2-2) unstable; urgency=medium

  * Build python3-powerline binary package (Closes: #798930)
  * Compile /usr/bin/powerline with extra hardening flags
  * Make sphinx-generated manpages reproducible

 -- Jerome Charaoui <jerome@riseup.net>  Sun, 18 Oct 2015 18:18:19 -0400

powerline (2.2-1) unstable; urgency=medium

  * Imported Upstream version 2.2
  * Distribute NEWS file only in powerline binary package (Closes: #792359)

 -- Jerome Charaoui <jerome@riseup.net>  Tue, 04 Aug 2015 22:04:48 -0400

powerline (2.1.4-1) unstable; urgency=medium

  * Import Upstream version 2.1. (Closes: #778250)

 -- Jerome Charaoui <jerome@riseup.net>  Sat, 23 May 2015 08:31:28 -0400

powerline (2.1-1) unstable; urgency=medium

  * Import Upstream version 2.1 (Closes: #776725)

 -- Jerome Charaoui <jerome@riseup.net>  Sun, 08 Mar 2015 14:48:15 -0400

powerline (1.2-2) unstable; urgency=medium

  * Fix incomplete tmux configuration by adjusting hardcoded bindings
    directory (Closes: #766637)

 -- Jerome Charaoui <jerome@riseup.net>  Sat, 25 Oct 2014 10:44:31 -0400

powerline (1.2-1) unstable; urgency=medium

  * Import Upstream version 1.2
  * Package is now architecture specific due to C component
  * Disable build tests for this release
  * Watch file modified to track upstream releases

 -- Jerome Charaoui <jerome@riseup.net>  Sat, 18 Oct 2014 15:26:20 -0400

powerline (0~20140216-2) unstable; urgency=low

  * Adjust package sections and descriptions (Closes: #753663, #753665)
  * Import upstream commit, fixes powerline with psutil 2.x (Closes: #758162)
  * Move bindings and config_files in powerline package (Closes: #758551)
  * Add README.Debian with installation and configuration instructions
      (Closes: #761474)

 -- Jerome Charaoui <jerome@riseup.net>  Thu, 18 Sep 2014 02:11:12 -0400

powerline (0~20140216-1) unstable; urgency=low

  * Initial release. (Closes: #739666)

 -- Jerome Charaoui <jerome@riseup.net>  Thu, 20 Feb 2014 23:06:16 -0500