diff options
author | Daniel Baumann <daniel.baumann@progress-linux.org> | 2024-04-27 16:03:18 +0000 |
---|---|---|
committer | Daniel Baumann <daniel.baumann@progress-linux.org> | 2024-04-27 16:03:18 +0000 |
commit | 2dd5bc6a074165ddfbd57c4bd52c2d2dac8f47a1 (patch) | |
tree | 465b29cb405d3af0b0ad50c78e1dccc636594fec /orc.mak | |
parent | Initial commit. (diff) | |
download | pulseaudio-2dd5bc6a074165ddfbd57c4bd52c2d2dac8f47a1.tar.xz pulseaudio-2dd5bc6a074165ddfbd57c4bd52c2d2dac8f47a1.zip |
Adding upstream version 14.2.upstream/14.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'orc.mak')
-rw-r--r-- | orc.mak | 48 |
1 files changed, 48 insertions, 0 deletions
@@ -0,0 +1,48 @@ +# +# This is a Makefile.am fragment to build Orc code. It is based +# on the orc.mak file distributed in the GStreamer common +# repository. +# +# Include this file like this: +# +# include $(top_srcdir)/orc.mak +# +# For each Orc source file, append its name (without the extension) +# to ORC_SOURCE: +# +# ORC_SOURCE += gstadderorc +# +# This will create gstadder-orc-gen.c and gstadder-orc-gen.h, which +# you need to add to your nodist_module_SOURCES. +# +# Note that this file appends to BUILT_SOURCES and CLEANFILES, so +# define them before including this file. +# + + +EXTRA_DIST += $(addsuffix .orc,$(ORC_SOURCE)) + +if HAVE_ORC +ORC_BUILT_SOURCE = $(addsuffix -orc-gen.c,$(ORC_SOURCE)) +ORC_BUILT_HEADER = $(addsuffix -orc-gen.h,$(ORC_SOURCE)) + +BUILT_SOURCES += $(ORC_BUILT_SOURCE) $(ORC_BUILT_HEADER) +CLEANFILES += $(BUILT_SOURCES) + + +orcc_v_gen = $(orcc_v_gen_$(V)) +orcc_v_gen_ = $(orcc_v_gen_$(AM_DEFAULT_VERBOSITY)) +orcc_v_gen_0 = @echo " ORCC $@"; + +cp_v_gen = $(cp_v_gen_$(V)) +cp_v_gen_ = $(cp_v_gen_$(AM_DEFAULT_VERBOSITY)) +cp_v_gen_0 = @echo " CP $@"; + +%-orc-gen.c: %.orc + @mkdir -p $(@D) + $(orcc_v_gen)$(ORCC) --implementation -o $@ $< + +%-orc-gen.h: %.orc + @mkdir -p $(@D) + $(orcc_v_gen)$(ORCC) --header -o $@ $< +endif |