summaryrefslogtreecommitdiffstats
path: root/shell-completion/zsh/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'shell-completion/zsh/meson.build')
-rw-r--r--shell-completion/zsh/meson.build48
1 files changed, 48 insertions, 0 deletions
diff --git a/shell-completion/zsh/meson.build b/shell-completion/zsh/meson.build
new file mode 100644
index 0000000..4fff133
--- /dev/null
+++ b/shell-completion/zsh/meson.build
@@ -0,0 +1,48 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+zshcompletiondir = get_option('zshcompletiondir')
+if zshcompletiondir == ''
+ zshcompletiondir = join_paths(datadir, 'zsh/site-functions')
+endif
+
+if zshcompletiondir != 'no'
+ zsh_systemctl = configure_file(
+ input : '_systemctl.in',
+ output : '_systemctl',
+ configuration : substs)
+
+ items = [['_busctl', ''],
+ ['_journalctl', ''],
+ ['_systemd-analyze', ''],
+ ['_systemd-delta', ''],
+ ['_systemd-nspawn', ''],
+ ['_systemd', ''],
+ ['_systemd-path', ''],
+ ['_systemd-run', ''],
+ ['_udevadm', ''],
+ ['_kernel-install', ''],
+ ['_sd_hosts_or_user_at_host', ''],
+ ['_sd_outputmodes', ''],
+ ['_sd_unit_files', ''],
+ ['_sd_machines', ''],
+ [zsh_systemctl, ''],
+ ['_bootctl', 'ENABLE_EFI'],
+ ['_coredumpctl', 'ENABLE_COREDUMP'],
+ ['_hostnamectl', 'ENABLE_HOSTNAMED'],
+ ['_localectl', 'ENABLE_LOCALED'],
+ ['_loginctl', 'ENABLE_LOGIND'],
+ ['_machinectl', 'ENABLE_MACHINED'],
+ ['_networkctl', 'ENABLE_NETWORKD'],
+ ['_systemd-inhibit', 'ENABLE_LOGIND'],
+ ['_resolvectl', 'ENABLE_RESOLVE'],
+ ['_systemd-tmpfiles', 'ENABLE_TMPFILES'],
+ ['_timedatectl', 'ENABLE_TIMEDATED'],
+ ]
+
+ foreach item : items
+ if item[1] == '' or conf.get(item[1]) == 1
+ install_data(item[0],
+ install_dir : zshcompletiondir)
+ endif
+ endforeach
+endif