summaryrefslogtreecommitdiffstats
path: root/src/VBox/HostDrivers/VBoxUSB/solaris/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:19:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 14:19:18 +0000
commit4035b1bfb1e5843a539a8b624d21952b756974d1 (patch)
treef1e9cd5bf548cbc57ff2fddfb2b4aa9ae95587e2 /src/VBox/HostDrivers/VBoxUSB/solaris/Makefile.kmk
parentInitial commit. (diff)
downloadvirtualbox-4035b1bfb1e5843a539a8b624d21952b756974d1.tar.xz
virtualbox-4035b1bfb1e5843a539a8b624d21952b756974d1.zip
Adding upstream version 6.1.22-dfsg.upstream/6.1.22-dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/VBox/HostDrivers/VBoxUSB/solaris/Makefile.kmk')
-rw-r--r--src/VBox/HostDrivers/VBoxUSB/solaris/Makefile.kmk57
1 files changed, 57 insertions, 0 deletions
diff --git a/src/VBox/HostDrivers/VBoxUSB/solaris/Makefile.kmk b/src/VBox/HostDrivers/VBoxUSB/solaris/Makefile.kmk
new file mode 100644
index 00000000..9a758402
--- /dev/null
+++ b/src/VBox/HostDrivers/VBoxUSB/solaris/Makefile.kmk
@@ -0,0 +1,57 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for the Solaris VBoxUSB kernel extension.
+#
+
+#
+# Copyright (C) 2008-2020 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+# The contents of this file may alternatively be used under the terms
+# of the Common Development and Distribution License Version 1.0
+# (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+# VirtualBox OSE distribution, in which case the provisions of the
+# CDDL are applicable instead of those of the GPL.
+#
+# You may elect to license modified versions of this file under the
+# terms and conditions of either the GPL or the CDDL or both.
+#
+
+SUB_DEPTH = ../../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+#
+# vboxusbmon - The Solaris USB Monitor Kernel module.
+#
+SYSMODS.solaris += vboxusbmon
+vboxusbmon_TEMPLATE = VBOXR0DRV
+vboxusbmon_DEFS = IN_RT_R0 VBOX_SVN_REV=$(VBOX_SVN_REV)
+vboxusbmon_DEPS += $(VBOX_SVN_REV_KMK)
+vboxusbmon_INCS := . .. include
+vboxusbmon_LDFLAGS += -N drv/vboxdrv -N misc/usba
+vboxusbmon_SOURCES = \
+ VBoxUSBMon-solaris.c \
+ ../USBFilter.cpp \
+ ../VBoxUSBFilterMgr.cpp
+
+#
+# vboxusb - The Solaris Generic USB Client Kernel module.
+#
+SYSMODS.solaris += vboxusb
+vboxusb_TEMPLATE = VBOXR0DRV
+vboxusb_DEFS = IN_RT_R0 IN_SUP_R0 VBOX_SVN_REV=$(VBOX_SVN_REV)
+vboxusb_DEPS += $(VBOX_SVN_REV_KMK)
+vboxusb_INCS := . include/
+vboxusb_LDFLAGS += -N drv/vboxdrv -N drv/vboxusbmon -N misc/usba
+vboxusb_SOURCES = \
+ VBoxUSB-solaris.c
+
+include $(FILE_KBUILD_SUB_FOOTER)
+