summaryrefslogtreecommitdiffstats
path: root/include/.scm-settings
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--include/.scm-settings80
1 files changed, 80 insertions, 0 deletions
diff --git a/include/.scm-settings b/include/.scm-settings
new file mode 100644
index 00000000..1dd7dbc0
--- /dev/null
+++ b/include/.scm-settings
@@ -0,0 +1,80 @@
+# $Id: .scm-settings $
+## @file
+# Source code massager settings for the includes.
+#
+
+#
+# Copyright (C) 2010-2020 Oracle Corporation
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+
+# Default license for headers is dual GPL and CDDL.
+--license-ose-dual
+
+# Only the headers should be dual.
+/Makefile.kmk: --license-ose-gpl
+/.scm-settings: --license-ose-gpl
+
+# These three have no Oracle license or copyright stuff for some reason.
+/iprt/formats/elf-amd64.h: --no-update-license --no-update-copyright-year
+/iprt/formats/elf-common.h: --no-update-license --no-update-copyright-year
+/iprt/formats/elf-i386.h: --no-update-license --no-update-copyright-year
+/iprt/formats/elf-i386.h: --no-update-license --no-update-copyright-year
+
+# external copyright
+/iprt/formats/lx.h: --external-copyright
+
+# TODO: This is using LGPL with Oracle disclaimer. Implement.
+/VBox/VBoxKeyboard.h: --external-copyright --lgpl-disclaimer
+
+# Some of the graphics stuff is using MIT.
+/VBox/Graphics/HGSMI.h: --license-mit
+/VBox/Graphics/HGSMIBase.h: --license-mit
+/VBox/Graphics/HGSMIChannels.h: --license-mit
+/VBox/Graphics/HGSMIChSetup.h: --license-mit
+/VBox/Graphics/HGSMIContext.h: --license-mit
+/VBox/Graphics/HGSMIDefs.h: --license-mit
+/VBox/Graphics/VBoxVideo.h: --license-mit
+/VBox/Graphics/VBoxVideoErr.h: --license-mit
+/VBox/Graphics/VBoxVideoGuest.h: --license-mit
+/VBox/Graphics/VBoxVideoVBE.h: --license-mit
+/VBox/Graphics/VBoxVideoVBEPrivate.h: --license-mit
+
+# And so are some files used by the shared folder guest code.
+/VBox/shflsvc.h: --license-mit
+/VBox/VBoxGuest.h: --license-mit
+/VBox/VBoxGuestCoreTypes.h: --license-mit
+/VBox/VBoxGuestLib.h: --license-mit
+/VBox/VBoxGuestLibSharedFolders.h: --license-mit
+/VBox/VBoxGuestLibSharedFoldersInline.h: --license-mit
+/VBox/VMMDev.h: --license-mit
+/VBox/VMMDevCoreTypes.h: --license-mit
+
+/VBox/HostServices/glext.h: --external-copyright --no-convert-tabs --no-strip-trailing-blanks
+/VBox/HostServices/glxext.h: --external-copyright --no-convert-tabs --no-strip-trailing-blanks
+/VBox/HostServices/wglext.h: --external-copyright --no-convert-tabs --no-strip-trailing-blanks
+
+# Some headers actually shouldn't have include guards:
+/VBox/dbus-calls.h: --no-fix-header-guards
+/VBox/VDEPlugSymDefs.h: --no-fix-header-guards
+/iprt/asn1-generator-core.h: --no-fix-header-guards
+/iprt/asn1-generator-pass.h: --no-fix-header-guards
+/iprt/asn1-generator-sanity.h: --no-fix-header-guards
+/iprt/asn1-generator-internal-header.h: --no-fix-header-guards
+/iprt/asn1-generator-asn1-decoder.h: --no-fix-header-guards
+/iprt/asn1-generator-init.h: --no-fix-header-guards
+/iprt/runtime-loader.h: --no-fix-header-guards
+/iprt/bldprog-strtab-template.cpp.h: --no-fix-header-guards
+/iprt/asm*watcom*.h: --no-pragma-once
+
+/iprt/*.h: --guard-relative-to-dir iprt --guard-prefix IPRT_INCLUDED_
+/VBox/*.h: --guard-relative-to-dir VBox --guard-prefix VBOX_INCLUDED_
+