summaryrefslogtreecommitdiffstats
path: root/src/VBox/Runtime/win/amd64
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Runtime/win/amd64')
-rw-r--r--src/VBox/Runtime/win/amd64/ASMAtomicBitClear.asm44
-rw-r--r--src/VBox/Runtime/win/amd64/ASMAtomicBitTestAndToggle.asm46
-rw-r--r--src/VBox/Runtime/win/amd64/ASMAtomicBitToggle.asm43
-rw-r--r--src/VBox/Runtime/win/amd64/ASMAtomicReadU64.asm45
-rw-r--r--src/VBox/Runtime/win/amd64/ASMAtomicXchgU8.asm42
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetCS.asm42
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetDR0.asm47
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetDR1.asm46
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetDR2.asm47
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetDR3.asm47
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetDR6.asm46
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetDR7.asm45
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetDS.asm41
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetES.asm41
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetFS.asm41
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetGS.asm41
-rw-r--r--src/VBox/Runtime/win/amd64/ASMGetSS.asm41
-rw-r--r--src/VBox/Runtime/win/amd64/ASMProbeReadByte.asm48
-rw-r--r--src/VBox/Runtime/win/amd64/Makefile.kup0
19 files changed, 793 insertions, 0 deletions
diff --git a/src/VBox/Runtime/win/amd64/ASMAtomicBitClear.asm b/src/VBox/Runtime/win/amd64/ASMAtomicBitClear.asm
new file mode 100644
index 00000000..fadc734e
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMAtomicBitClear.asm
@@ -0,0 +1,44 @@
+;; @file
+; IPRT - ASMAtomicBitClear().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Atomically clears a bit in a bitmap.
+;
+; @param rcx pvBitmap Pointer to the bitmap.
+; @param edx iBit The bit to toggle set.
+; @remark No memory barrier, take care on smp.
+;
+BEGINPROC_EXPORTED ASMAtomicBitClear
+ lock btr [rcx], edx
+ ret
+ENDPROC ASMAtomicBitClear
+
diff --git a/src/VBox/Runtime/win/amd64/ASMAtomicBitTestAndToggle.asm b/src/VBox/Runtime/win/amd64/ASMAtomicBitTestAndToggle.asm
new file mode 100644
index 00000000..e8460458
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMAtomicBitTestAndToggle.asm
@@ -0,0 +1,46 @@
+;; @file
+; IPRT - ASMAtomicBitTestAndToggle().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Atomically tests and toggles a bit in a bitmap.
+;
+; @returns al(rax) true if the bit was set.
+; @returns al(rax) false if the bit was clear.
+; @param rcx pvBitmap Pointer to the bitmap.
+; @param edx iBit The bit to test and toggle.
+BEGINPROC_EXPORTED ASMAtomicBitTestAndToggle
+ lock btc [rcx], edx
+ sbb eax, eax
+ ret
+ENDPROC ASMAtomicBitTestAndToggle
+
diff --git a/src/VBox/Runtime/win/amd64/ASMAtomicBitToggle.asm b/src/VBox/Runtime/win/amd64/ASMAtomicBitToggle.asm
new file mode 100644
index 00000000..40b0b10d
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMAtomicBitToggle.asm
@@ -0,0 +1,43 @@
+;; @file
+; IPRT - ASMAtomicBitToggle().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Atomically toggles a bit in a bitmap.
+;
+; @param rcx pvBitmap Pointer to the bitmap.
+; @param edx iBit The bit to test and set.
+BEGINPROC_EXPORTED ASMAtomicBitToggle
+ lock btc [rcx], edx
+ ret
+ENDPROC ASMAtomicBitToggle
+
diff --git a/src/VBox/Runtime/win/amd64/ASMAtomicReadU64.asm b/src/VBox/Runtime/win/amd64/ASMAtomicReadU64.asm
new file mode 100644
index 00000000..354b9217
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMAtomicReadU64.asm
@@ -0,0 +1,45 @@
+;; @file
+; IPRT - ASMAtomicReadU64().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Atomically Reads a unsigned 64-bit value.
+;
+; @returns rax Current *pu64 value
+; @param rcx pu64 Pointer to the 64-bit variable to read.
+; The memory pointed to must be writable.
+;
+BEGINPROC_EXPORTED ASMAtomicReadU64
+ mov rax, [rcx]
+ ret
+ENDPROC ASMAtomicReadU64
+
diff --git a/src/VBox/Runtime/win/amd64/ASMAtomicXchgU8.asm b/src/VBox/Runtime/win/amd64/ASMAtomicXchgU8.asm
new file mode 100644
index 00000000..f5baa2db
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMAtomicXchgU8.asm
@@ -0,0 +1,42 @@
+;; @file
+; IPRT - ASMAtomicXchgU8().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; @returns al Current *pu8 value
+; @param rcx pu8 Pointer to the 8-bit variable to update.
+; @param dl u8 The 8-bit value to assign to *pu8.
+BEGINPROC_EXPORTED ASMAtomicXchgU8
+ xchg [rcx], dl
+ movzx eax, dl
+ ret
+ENDPROC ASMAtomicXchgU8
+
diff --git a/src/VBox/Runtime/win/amd64/ASMGetCS.asm b/src/VBox/Runtime/win/amd64/ASMGetCS.asm
new file mode 100644
index 00000000..89fe9365
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetCS.asm
@@ -0,0 +1,42 @@
+;; @file
+; IPRT - ASMGetCS().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the cs register.
+; @returns cs.
+;
+BEGINPROC_EXPORTED ASMGetCS
+ mov eax, cs
+ ret
+ENDPROC ASMGetCS
+
diff --git a/src/VBox/Runtime/win/amd64/ASMGetDR0.asm b/src/VBox/Runtime/win/amd64/ASMGetDR0.asm
new file mode 100644
index 00000000..1ab740eb
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetDR0.asm
@@ -0,0 +1,47 @@
+;; @file
+; IPRT - ASMGetDR0().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the dr0 register value.
+; @returns dr0.
+;
+BEGINPROC_EXPORTED ASMGetDR0
+ mov rax, dr0
+ ret
+ENDPROC ASMGetDR0
+
+
+BEGINPROC_EXPORTED ASMSetDR0
+ mov dr0, rcx
+ ret
+ENDPROC ASMSetDR0
diff --git a/src/VBox/Runtime/win/amd64/ASMGetDR1.asm b/src/VBox/Runtime/win/amd64/ASMGetDR1.asm
new file mode 100644
index 00000000..1afe8567
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetDR1.asm
@@ -0,0 +1,46 @@
+;; @file
+; IPRT - ASMGetDR1().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the dr1 register value.
+; @returns dr1.
+;
+BEGINPROC_EXPORTED ASMGetDR1
+ mov rax, dr1
+ ret
+ENDPROC ASMGetDR1
+
+
+BEGINPROC_EXPORTED ASMSetDR1
+ mov dr1, rcx
+ ret
+ENDPROC ASMSetDR1
diff --git a/src/VBox/Runtime/win/amd64/ASMGetDR2.asm b/src/VBox/Runtime/win/amd64/ASMGetDR2.asm
new file mode 100644
index 00000000..b09bcdb0
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetDR2.asm
@@ -0,0 +1,47 @@
+;; @file
+; IPRT - ASMGetDR2().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the dr2 register value.
+; @returns dr2.
+;
+BEGINPROC_EXPORTED ASMGetDR2
+ mov rax, dr2
+ ret
+ENDPROC ASMGetDR2
+
+
+BEGINPROC_EXPORTED ASMSetDR2
+ mov dr2, rcx
+ ret
+ENDPROC ASMSetDR2
diff --git a/src/VBox/Runtime/win/amd64/ASMGetDR3.asm b/src/VBox/Runtime/win/amd64/ASMGetDR3.asm
new file mode 100644
index 00000000..e11e0a7d
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetDR3.asm
@@ -0,0 +1,47 @@
+;; @file
+; IPRT - ASMGetDR3().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the dr3 register value.
+; @returns dr3.
+;
+BEGINPROC_EXPORTED ASMGetDR3
+ mov rax, dr3
+ ret
+ENDPROC ASMGetDR3
+
+
+BEGINPROC_EXPORTED ASMSetDR3
+ mov dr3, rcx
+ ret
+ENDPROC ASMSetDR3
diff --git a/src/VBox/Runtime/win/amd64/ASMGetDR6.asm b/src/VBox/Runtime/win/amd64/ASMGetDR6.asm
new file mode 100644
index 00000000..16634db0
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetDR6.asm
@@ -0,0 +1,46 @@
+;; @file
+; IPRT - ASMGetDR6().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the dr6 register value.
+; @returns dr6.
+;
+BEGINPROC_EXPORTED ASMGetDR6
+ mov rax, dr6
+ ret
+ENDPROC ASMGetDR6
+
+
+BEGINPROC_EXPORTED ASMSetDR6
+ mov dr6, rcx
+ ret
+ENDPROC ASMSetDR6
diff --git a/src/VBox/Runtime/win/amd64/ASMGetDR7.asm b/src/VBox/Runtime/win/amd64/ASMGetDR7.asm
new file mode 100644
index 00000000..7a029671
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetDR7.asm
@@ -0,0 +1,45 @@
+;; @file
+; IPRT - ASMGetDR7().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the dr7 register value.
+; @returns dr7.
+;
+BEGINPROC_EXPORTED ASMGetDR7
+ mov rax, dr7
+ ret
+ENDPROC ASMGetDR7
+
+BEGINPROC_EXPORTED ASMSetDR7
+ mov dr7, rcx
+ ret
+ENDPROC ASMSetDR7
diff --git a/src/VBox/Runtime/win/amd64/ASMGetDS.asm b/src/VBox/Runtime/win/amd64/ASMGetDS.asm
new file mode 100644
index 00000000..5e5897f7
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetDS.asm
@@ -0,0 +1,41 @@
+;; @file
+; IPRT - ASMGetDS().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the ds register.
+; @returns ds.
+;
+BEGINPROC_EXPORTED ASMGetDS
+ mov eax, DS
+ ret
+ENDPROC ASMGetDS
+
diff --git a/src/VBox/Runtime/win/amd64/ASMGetES.asm b/src/VBox/Runtime/win/amd64/ASMGetES.asm
new file mode 100644
index 00000000..4e395d91
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetES.asm
@@ -0,0 +1,41 @@
+;; @file
+; IPRT - ASMGetES().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the es register.
+; @returns es.
+;
+BEGINPROC_EXPORTED ASMGetES
+ mov eax, es
+ ret
+ENDPROC ASMGetES
+
diff --git a/src/VBox/Runtime/win/amd64/ASMGetFS.asm b/src/VBox/Runtime/win/amd64/ASMGetFS.asm
new file mode 100644
index 00000000..2b6ea9d7
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetFS.asm
@@ -0,0 +1,41 @@
+;; @file
+; IPRT - ASMGetFS().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the fs register.
+; @returns fs.
+;
+BEGINPROC_EXPORTED ASMGetFS
+ mov eax, fs
+ ret
+ENDPROC ASMGetFS
+
diff --git a/src/VBox/Runtime/win/amd64/ASMGetGS.asm b/src/VBox/Runtime/win/amd64/ASMGetGS.asm
new file mode 100644
index 00000000..5a77aff6
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetGS.asm
@@ -0,0 +1,41 @@
+;; @file
+; IPRT - ASMGetGS().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the gs register.
+; @returns gs.
+;
+BEGINPROC_EXPORTED ASMGetGS
+ mov eax, gs
+ ret
+ENDPROC ASMGetGS
+
diff --git a/src/VBox/Runtime/win/amd64/ASMGetSS.asm b/src/VBox/Runtime/win/amd64/ASMGetSS.asm
new file mode 100644
index 00000000..b9bf519c
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMGetSS.asm
@@ -0,0 +1,41 @@
+;; @file
+; IPRT - ASMGetSS().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Get the ss register.
+; @returns ss.
+;
+BEGINPROC_EXPORTED ASMGetSS
+ mov eax, ss
+ ret
+ENDPROC ASMGetSS
+
diff --git a/src/VBox/Runtime/win/amd64/ASMProbeReadByte.asm b/src/VBox/Runtime/win/amd64/ASMProbeReadByte.asm
new file mode 100644
index 00000000..28a3fd53
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/ASMProbeReadByte.asm
@@ -0,0 +1,48 @@
+;; @file
+; IPRT - ASMProbeReadByte().
+;
+
+;
+; Copyright (C) 2006-2020 Oracle Corporation
+;
+; This file is part of VirtualBox Open Source Edition (OSE), as
+; available from http://www.virtualbox.org. This file is free software;
+; you can redistribute it and/or modify it under the terms of the GNU
+; General Public License (GPL) as published by the Free Software
+; Foundation, in version 2 as it comes in the "COPYING" file of the
+; VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+; hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+;
+; The contents of this file may alternatively be used under the terms
+; of the Common Development and Distribution License Version 1.0
+; (CDDL) only, as it comes in the "COPYING.CDDL" file of the
+; VirtualBox OSE distribution, in which case the provisions of the
+; CDDL are applicable instead of those of the GPL.
+;
+; You may elect to license modified versions of this file under the
+; terms and conditions of either the GPL or the CDDL or both.
+;
+
+;*******************************************************************************
+;* Header Files *
+;*******************************************************************************
+%include "iprt/asmdefs.mac"
+
+BEGINCODE
+
+;;
+; Probes a byte pointer for read access.
+;
+; While the function will not fault if the byte is not read accessible,
+; the idea is to do this in a safe place like before acquiring locks
+; and such like.
+;
+; Also, this functions guarantees that an eager compiler is not going
+; to optimize the probing away.
+;
+; @param rcx pvByte Pointer to the byte.
+BEGINPROC_EXPORTED ASMProbeReadByte
+ mov al, [rcx]
+ ret
+ENDPROC ASMProbeReadByte
+
diff --git a/src/VBox/Runtime/win/amd64/Makefile.kup b/src/VBox/Runtime/win/amd64/Makefile.kup
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/src/VBox/Runtime/win/amd64/Makefile.kup