summaryrefslogtreecommitdiffstats
path: root/make-srpm.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /make-srpm.sh
parentInitial commit. (diff)
downloadceph-upstream/18.2.2.tar.xz
ceph-upstream/18.2.2.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'make-srpm.sh')
-rwxr-xr-xmake-srpm.sh11
1 files changed, 11 insertions, 0 deletions
diff --git a/make-srpm.sh b/make-srpm.sh
new file mode 100755
index 000000000..1ba0ff088
--- /dev/null
+++ b/make-srpm.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+#
+# Create a SRPM which can be used to build Ceph
+#
+# ./make-srpm.sh <version>
+# rpmbuild --rebuild /tmp/ceph/ceph-<version>-0.el7.centos.src.rpm
+#
+
+./make-dist $1
+rpmbuild -D"_sourcedir `pwd`" -D"_specdir `pwd`" -D"_srcrpmdir `pwd`" -bs ceph.spec