summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/bind/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/boost/libs/bind/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/18.2.2.tar.xz
ceph-upstream/18.2.2.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/bind/CMakeLists.txt')
-rw-r--r--src/boost/libs/bind/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/boost/libs/bind/CMakeLists.txt b/src/boost/libs/bind/CMakeLists.txt
new file mode 100644
index 000000000..63e18443d
--- /dev/null
+++ b/src/boost/libs/bind/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Copyright 2018, 2019 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.5...3.16)
+
+project(boost_bind VERSION "${BOOST_SUPERPROJECT_VERSION}" LANGUAGES CXX)
+
+add_library(boost_bind INTERFACE)
+add_library(Boost::bind ALIAS boost_bind)
+
+target_include_directories(boost_bind INTERFACE include)
+
+target_link_libraries(boost_bind
+ INTERFACE
+ Boost::config
+ Boost::core
+)
+
+if(BUILD_TESTING)
+
+ add_subdirectory(test)
+
+endif()