summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/proto/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/boost/libs/proto/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/18.2.2.tar.xz
ceph-upstream/18.2.2.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/proto/CMakeLists.txt')
-rw-r--r--src/boost/libs/proto/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/boost/libs/proto/CMakeLists.txt b/src/boost/libs/proto/CMakeLists.txt
new file mode 100644
index 000000000..c16453956
--- /dev/null
+++ b/src/boost/libs/proto/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated by `boostdep --cmake proto`
+# Copyright 2020 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# https://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.5...3.16)
+
+project(boost_proto VERSION "${BOOST_SUPERPROJECT_VERSION}" LANGUAGES CXX)
+
+add_library(boost_proto INTERFACE)
+add_library(Boost::proto ALIAS boost_proto)
+
+target_include_directories(boost_proto INTERFACE include)
+
+target_link_libraries(boost_proto
+ INTERFACE
+ Boost::config
+ Boost::core
+ Boost::fusion
+ Boost::mpl
+ Boost::preprocessor
+ Boost::range
+ Boost::static_assert
+ Boost::type_traits
+ Boost::typeof
+ Boost::utility
+)
+
+if(BUILD_TESTING AND EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/test/CMakeLists.txt")
+
+ add_subdirectory(test)
+
+endif()
+