summaryrefslogtreecommitdiffstats
path: root/src/ceph-volume/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/ceph-volume/setup.py
parentInitial commit. (diff)
downloadceph-upstream/18.2.2.tar.xz
ceph-upstream/18.2.2.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/ceph-volume/setup.py')
-rw-r--r--src/ceph-volume/setup.py42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/ceph-volume/setup.py b/src/ceph-volume/setup.py
new file mode 100644
index 000000000..44a0d0e46
--- /dev/null
+++ b/src/ceph-volume/setup.py
@@ -0,0 +1,42 @@
+from setuptools import setup, find_packages
+import os
+
+
+setup(
+ name='ceph-volume',
+ version='1.0.0',
+ packages=find_packages(),
+
+ author='',
+ author_email='contact@redhat.com',
+ description='Deploy Ceph OSDs using different device technologies like lvm or physical disks',
+ license='LGPLv2+',
+ keywords='ceph volume disk devices lvm',
+ url="https://github.com/ceph/ceph",
+ zip_safe = False,
+ install_requires='ceph',
+ dependency_links=[''.join(['file://', os.path.join(os.getcwd(), '../',
+ 'python-common#egg=ceph-1.0.0')])],
+ tests_require=[
+ 'pytest >=2.1.3',
+ 'tox',
+ 'ceph',
+ ],
+ entry_points = dict(
+ console_scripts = [
+ 'ceph-volume = ceph_volume.main:Volume',
+ 'ceph-volume-systemd = ceph_volume.systemd:main',
+ ],
+ ),
+ classifiers = [
+ 'Environment :: Console',
+ 'Intended Audience :: Information Technology',
+ 'Intended Audience :: System Administrators',
+ 'Operating System :: POSIX :: Linux',
+ 'License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ ]
+)