summaryrefslogtreecommitdiffstats
path: root/src/fmt/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/fmt/doc/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-b26c4052f3542036551aa9dec9caa4226e456195.tar.xz
ceph-b26c4052f3542036551aa9dec9caa4226e456195.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/fmt/doc/CMakeLists.txt')
-rw-r--r--src/fmt/doc/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/fmt/doc/CMakeLists.txt b/src/fmt/doc/CMakeLists.txt
new file mode 100644
index 000000000..fd9f4d1e4
--- /dev/null
+++ b/src/fmt/doc/CMakeLists.txt
@@ -0,0 +1,26 @@
+find_program(DOXYGEN doxygen
+ PATHS "$ENV{ProgramFiles}/doxygen/bin"
+ "$ENV{ProgramFiles\(x86\)}/doxygen/bin")
+if (NOT DOXYGEN)
+ message(STATUS "Target 'doc' disabled (requires doxygen)")
+ return ()
+endif ()
+
+# Find the Python interpreter and set the PYTHON_EXECUTABLE variable.
+if (CMAKE_VERSION VERSION_LESS 3.12)
+ # This logic is deprecated in CMake after 3.12.
+ find_package(PythonInterp QUIET REQUIRED)
+else ()
+ find_package(Python QUIET REQUIRED)
+ set(PYTHON_EXECUTABLE ${Python_EXECUTABLE})
+endif ()
+
+add_custom_target(doc
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/build.py
+ ${FMT_VERSION}
+ SOURCES api.rst syntax.rst usage.rst build.py conf.py _templates/layout.html)
+
+include(GNUInstallDirs)
+install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html/
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/doc/fmt OPTIONAL
+ PATTERN ".doctrees" EXCLUDE)