summaryrefslogtreecommitdiffstats
path: root/src/libradosstriper/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/libradosstriper/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/libradosstriper/CMakeLists.txt')
-rw-r--r--src/libradosstriper/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/libradosstriper/CMakeLists.txt b/src/libradosstriper/CMakeLists.txt
new file mode 100644
index 000000000..a69192465
--- /dev/null
+++ b/src/libradosstriper/CMakeLists.txt
@@ -0,0 +1,17 @@
+set(libradosstriper_srcs
+ libradosstriper.cc
+ RadosStriperImpl.cc
+ MultiAioCompletionImpl.cc)
+add_library(radosstriper ${CEPH_SHARED}
+ ${libradosstriper_srcs})
+target_link_libraries(radosstriper
+ PRIVATE
+ librados
+ librados_impl cls_lock_client osdc ceph-common
+ pthread ${CRYPTO_LIBS} ${EXTRALIBS})
+set_target_properties(radosstriper PROPERTIES
+ OUPUT_NAME radosstriper
+ VERSION 1.0.0
+ SOVERSION 1)
+
+install(TARGETS radosstriper DESTINATION ${CMAKE_INSTALL_LIBDIR})