summaryrefslogtreecommitdiffstats
path: root/src/spdk/ocf/tests/build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/spdk/ocf/tests/build
parentInitial commit. (diff)
downloadceph-upstream/18.2.2.tar.xz
ceph-upstream/18.2.2.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/ocf/tests/build')
-rw-r--r--src/spdk/ocf/tests/build/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/spdk/ocf/tests/build/Makefile b/src/spdk/ocf/tests/build/Makefile
new file mode 100644
index 000000000..133bc1004
--- /dev/null
+++ b/src/spdk/ocf/tests/build/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright(c) 2019 Intel Corporation
+# SPDX-License-Identifier: BSD-3-Clause-Clear
+#
+
+#
+# This Makefile performs basic build test of OCF with posix environment.
+# It doesn't generate any final executable, but just compiles every
+# single *.c file into *.o object, to check if compilation succeeds.
+#
+# It's intended to be used as part of CI process.
+#
+
+OCFDIR=../../
+SRCDIR=src/
+INCDIR=include/
+
+SRC=$(shell find ${SRCDIR} -name \*.c)
+OBJS = $(patsubst %.c, %.o, $(SRC))
+CFLAGS = -Wall -Werror -I${INCDIR} -I${SRCDIR}/ocf/env/
+
+all: sync
+ $(MAKE) build
+
+build: $(OBJS)
+
+sync:
+ @$(MAKE) -C ${OCFDIR} inc O=$(PWD)
+ @$(MAKE) -C ${OCFDIR} src O=$(PWD)
+ @$(MAKE) -C ${OCFDIR} env O=$(PWD) OCF_ENV=posix
+
+clean:
+ @rm -rf $(OBJS)
+
+distclean:
+ @rm -rf $(OBJS)
+ @rm -rf src/ocf
+ @rm -rf include/ocf
+
+.PHONY: all build sync clean distclean