summaryrefslogtreecommitdiffstats
path: root/src/spdk/shared_lib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/spdk/shared_lib
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/shared_lib')
-rw-r--r--src/spdk/shared_lib/Makefile70
1 files changed, 70 insertions, 0 deletions
diff --git a/src/spdk/shared_lib/Makefile b/src/spdk/shared_lib/Makefile
new file mode 100644
index 000000000..f6d70cfe7
--- /dev/null
+++ b/src/spdk/shared_lib/Makefile
@@ -0,0 +1,70 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.app.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.modules.mk
+
+SO_VER := 2
+SO_MINOR := 0
+
+# Build combined libspdk.so shared library
+SHARED_LINKED_LIB := $(SPDK_ROOT_DIR)/build/lib/libspdk.so
+SHARED_REALNAME_LIB := $(SHARED_LINKED_LIB).$(SO_SUFFIX)
+IGNORED_LIBS := libspdk.so
+IGNORED_LIBS += libspdk_ut_mock.so
+IGNORED_LIBS += libspdk_env_dpdk.so
+
+SPDK_SHARED_LIBS := $(filter-out $(IGNORED_LIBS), $(sort $(notdir $(wildcard $(SPDK_ROOT_DIR)/build/lib/*.so))))
+
+$(SHARED_REALNAME_LIB):
+ $(Q)echo " SO $(notdir $@)"; \
+ echo "GROUP ( $(SPDK_SHARED_LIBS) )" > $(SHARED_REALNAME_LIB)
+
+$(SHARED_LINKED_LIB) : $(SHARED_REALNAME_LIB)
+ $(Q)echo " SYMLINK $(notdir $@)"; $(BUILD_LINKERNAME_LIB)
+
+.PHONY: all clean $(DIRS-y) $(SHARED_LINKED_LIB) install uninstall
+
+all: $(SHARED_LINKED_LIB)
+
+CLEAN_FILES += $(SHARED_REALNAME_LIB) $(SHARED_LINKED_LIB)
+
+install:
+ $(INSTALL_SHARED_LIB)
+
+uninstall:
+ $(UNINSTALL_SHARED_LIB)
+
+include $(SPDK_ROOT_DIR)/mk/spdk.subdirs.mk