summaryrefslogtreecommitdiffstats
path: root/src/test/client/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/test/client/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/18.2.2.tar.xz
ceph-upstream/18.2.2.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/test/client/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/test/client/CMakeLists.txt b/src/test/client/CMakeLists.txt
new file mode 100644
index 000000000..1937bdd0b
--- /dev/null
+++ b/src/test/client/CMakeLists.txt
@@ -0,0 +1,17 @@
+if(${WITH_CEPHFS})
+ add_executable(ceph_test_client
+ main.cc
+ alternate_name.cc
+ ops.cc
+ )
+ target_link_libraries(ceph_test_client
+ client
+ global
+ ceph-common
+ ${UNITTEST_LIBS}
+ ${EXTRALIBS}
+ ${CMAKE_DL_LIBS}
+ )
+ install(TARGETS ceph_test_client
+ DESTINATION ${CMAKE_INSTALL_BINDIR})
+endif(${WITH_CEPHFS})