summaryrefslogtreecommitdiffstats
path: root/src/test/cls_rbd/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/test/cls_rbd/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/18.2.2.tar.xz
ceph-upstream/18.2.2.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/cls_rbd/CMakeLists.txt')
-rw-r--r--src/test/cls_rbd/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/test/cls_rbd/CMakeLists.txt b/src/test/cls_rbd/CMakeLists.txt
new file mode 100644
index 000000000..74c5804e7
--- /dev/null
+++ b/src/test/cls_rbd/CMakeLists.txt
@@ -0,0 +1,18 @@
+# cls_test_cls_rbd
+add_executable(ceph_test_cls_rbd
+ test_cls_rbd.cc
+ $<TARGET_OBJECTS:common_texttable_obj>)
+target_link_libraries(ceph_test_cls_rbd
+ cls_rbd_client
+ cls_lock_client
+ libneorados
+ librados
+ global
+ ${UNITTEST_LIBS}
+ ${CMAKE_DL_LIBS}
+ ${CRYPTO_LIBS}
+ ${EXTRALIBS}
+ radostest-cxx)
+install(TARGETS
+ ceph_test_cls_rbd
+ DESTINATION ${CMAKE_INSTALL_BINDIR})