summaryrefslogtreecommitdiffstats
path: root/src/test/exporter/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/test/exporter/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/18.2.2.tar.xz
ceph-upstream/18.2.2.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/exporter/CMakeLists.txt')
-rw-r--r--src/test/exporter/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/test/exporter/CMakeLists.txt b/src/test/exporter/CMakeLists.txt
new file mode 100644
index 000000000..7ef5631f8
--- /dev/null
+++ b/src/test/exporter/CMakeLists.txt
@@ -0,0 +1,12 @@
+add_executable(unittest_exporter
+ test_exporter.cc
+ "${CMAKE_SOURCE_DIR}/src/exporter/util.cc"
+ "${CMAKE_SOURCE_DIR}/src/exporter/DaemonMetricCollector.cc"
+ )
+
+target_link_libraries(unittest_exporter
+ global
+ ${UNITTEST_LIBS}
+ )
+add_ceph_unittest(unittest_exporter)
+