summaryrefslogtreecommitdiffstats
path: root/src/test/rgw/bucket_notification/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/test/rgw/bucket_notification/setup.py
parentInitial commit. (diff)
downloadceph-b26c4052f3542036551aa9dec9caa4226e456195.tar.xz
ceph-b26c4052f3542036551aa9dec9caa4226e456195.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/rgw/bucket_notification/setup.py')
-rw-r--r--src/test/rgw/bucket_notification/setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/test/rgw/bucket_notification/setup.py b/src/test/rgw/bucket_notification/setup.py
new file mode 100644
index 000000000..189ab27b4
--- /dev/null
+++ b/src/test/rgw/bucket_notification/setup.py
@@ -0,0 +1,19 @@
+#!/usr/bin/python
+from setuptools import setup, find_packages
+
+setup(
+ name='bn_tests',
+ version='0.0.1',
+ packages=find_packages(),
+
+ author='Kalpesh Pandya',
+ author_email='kapandya@redhat.com',
+ description='Bucket Notification compatibility tests',
+ license='MIT',
+ keywords='bn web testing',
+
+ install_requires=[
+ 'boto >=2.0b4',
+ 'boto3 >=1.0.0'
+ ],
+ )