summaryrefslogtreecommitdiffstats
path: root/src/utf8proc/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/utf8proc/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream/18.2.2.tar.xz
ceph-upstream/18.2.2.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/utf8proc/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/utf8proc/CMakeLists.txt b/src/utf8proc/CMakeLists.txt
new file mode 100644
index 000000000..e0d3f3f0b
--- /dev/null
+++ b/src/utf8proc/CMakeLists.txt
@@ -0,0 +1,51 @@
+cmake_minimum_required (VERSION 2.8.12)
+
+include (utils.cmake)
+
+disallow_intree_builds()
+
+project (utf8proc C)
+
+# This is the ABI version number, which may differ from the
+# API version number (defined in utf8proc.h).
+# Be sure to also update these in Makefile and MANIFEST!
+set(SO_MAJOR 2)
+set(SO_MINOR 2)
+set(SO_PATCH 0)
+
+if (NOT MSVC)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O2 -std=c99 -pedantic -Wall")
+endif ()
+
+add_library (utf8proc
+ utf8proc.c
+ utf8proc.h
+)
+
+if (BUILD_SHARED_LIBS)
+ # Building shared library
+else()
+ # Building static library
+ target_compile_definitions(utf8proc PUBLIC "UTF8PROC_STATIC")
+ if (MSVC)
+ set_target_properties(utf8proc PROPERTIES OUTPUT_NAME "utf8proc_static")
+ endif()
+endif()
+
+target_compile_definitions(utf8proc PRIVATE "UTF8PROC_EXPORTS")
+
+set_target_properties (utf8proc PROPERTIES
+ POSITION_INDEPENDENT_CODE ON
+ VERSION "${SO_MAJOR}.${SO_MINOR}.${SO_PATCH}"
+ SOVERSION ${SO_MAJOR}
+)
+
+install(TARGETS utf8proc
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib)
+
+install(
+ FILES
+ "${PROJECT_SOURCE_DIR}/utf8proc.h"
+ DESTINATION include)