summaryrefslogtreecommitdiffstats
path: root/src/utf8proc/utils.cmake
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-21 11:54:28 +0000
commite6918187568dbd01842d8d1d2c808ce16a894239 (patch)
tree64f88b554b444a49f656b6c656111a145cbbaa28 /src/utf8proc/utils.cmake
parentInitial commit. (diff)
downloadceph-e6918187568dbd01842d8d1d2c808ce16a894239.tar.xz
ceph-e6918187568dbd01842d8d1d2c808ce16a894239.zip
Adding upstream version 18.2.2.upstream/18.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/utf8proc/utils.cmake20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/utf8proc/utils.cmake b/src/utf8proc/utils.cmake
new file mode 100644
index 000000000..63fc426a3
--- /dev/null
+++ b/src/utf8proc/utils.cmake
@@ -0,0 +1,20 @@
+
+function (disallow_intree_builds)
+ # Adapted from LLVM's toplevel CMakeLists.txt file
+ if( CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR AND NOT MSVC_IDE )
+ message(FATAL_ERROR "
+ In-source builds are not allowed. CMake would overwrite the
+ makefiles distributed with utf8proc. Please create a directory
+ and run cmake from there. Building in a subdirectory is
+ fine, e.g.:
+
+ mkdir build
+ cd build
+ cmake ..
+
+ This process created the file `CMakeCache.txt' and the
+ directory `CMakeFiles'. Please delete them.
+
+ ")
+ endif()
+endfunction()