summaryrefslogtreecommitdiffstats
path: root/src/arrow/.dockerignore
diff options
context:
space:
mode:
Diffstat (limited to 'src/arrow/.dockerignore')
-rw-r--r--src/arrow/.dockerignore62
1 files changed, 62 insertions, 0 deletions
diff --git a/src/arrow/.dockerignore b/src/arrow/.dockerignore
new file mode 100644
index 000000000..a369d7d59
--- /dev/null
+++ b/src/arrow/.dockerignore
@@ -0,0 +1,62 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+# Turn .dockerignore to .dockerallow by excluding everything and explicitly
+# allowing specific files and directories. This enables us to quickly add
+# dependency files to the docker content without scanning the whole directory.
+# This setup requires to all of our docker containers have arrow's source
+# as a mounted directory.
+
+# exclude everything
+**
+
+# include explicitly
+!ci/**
+!c_glib/Gemfile
+!dev/archery/setup.py
+!python/requirements*.txt
+!python/manylinux1/**
+!python/manylinux2010/**
+!r/DESCRIPTION
+!ruby/Gemfile
+!ruby/red-arrow/Gemfile
+!ruby/red-arrow/lib/arrow/version.rb
+!ruby/red-arrow/red-arrow.gemspec
+!ruby/red-arrow-cuda/Gemfile
+!ruby/red-arrow-cuda/lib/arrow-cuda/version.rb
+!ruby/red-arrow-cuda/red-arrow-cuda.gemspec
+!ruby/red-gandiva/Gemfile
+!ruby/red-gandiva/lib/gandiva/version.rb
+!ruby/red-gandiva/red-gandiva.gemspec
+!ruby/red-parquet/Gemfile
+!ruby/red-parquet/lib/parquet/version.rb
+!ruby/red-parquet/red-parquet.gemspec
+!ruby/red-plasma/Gemfile
+!ruby/red-plasma/lib/plasma/version.rb
+!ruby/red-plasma/red-plasma.gemspec
+!rust/Cargo.toml
+!rust/benchmarks/Cargo.toml
+!rust/arrow/Cargo.toml
+!rust/arrow/benches
+!rust/arrow-flight/Cargo.toml
+!rust/parquet/Cargo.toml
+!rust/parquet/build.rs
+!rust/parquet_derive/Cargo.toml
+!rust/parquet_derive_test/Cargo.toml
+!rust/datafusion/Cargo.toml
+!rust/datafusion/benches
+!rust/integration-testing/Cargo.toml