summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/variant2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/variant2/CMakeLists.txt')
-rw-r--r--src/boost/libs/variant2/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/boost/libs/variant2/CMakeLists.txt b/src/boost/libs/variant2/CMakeLists.txt
new file mode 100644
index 000000000..38265770b
--- /dev/null
+++ b/src/boost/libs/variant2/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated by `boostdep --cmake variant2`
+# Copyright 2020, 2021 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# https://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.8...3.20)
+
+project(boost_variant2 VERSION "${BOOST_SUPERPROJECT_VERSION}" LANGUAGES CXX)
+
+add_library(boost_variant2 INTERFACE)
+add_library(Boost::variant2 ALIAS boost_variant2)
+
+target_include_directories(boost_variant2 INTERFACE include)
+
+target_link_libraries(boost_variant2
+ INTERFACE
+ Boost::assert
+ Boost::config
+ Boost::mp11
+)
+
+target_compile_features(boost_variant2 INTERFACE cxx_std_11)
+
+if(BUILD_TESTING AND EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/test/CMakeLists.txt")
+
+ add_subdirectory(test)
+
+endif()