summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/vmd/test/test_cmake
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/vmd/test/test_cmake')
-rw-r--r--src/boost/libs/vmd/test/test_cmake/CMakeLists.txt17
-rw-r--r--src/boost/libs/vmd/test/test_cmake/main.cpp9
2 files changed, 26 insertions, 0 deletions
diff --git a/src/boost/libs/vmd/test/test_cmake/CMakeLists.txt b/src/boost/libs/vmd/test/test_cmake/CMakeLists.txt
new file mode 100644
index 000000000..dc0d420b7
--- /dev/null
+++ b/src/boost/libs/vmd/test/test_cmake/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Copyright 2018 Mike Dev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+#
+# NOTE: This does NOT run the unit tests for Boost.Vmd.
+# It only tests, if the CMakeLists.txt file in it's root works as expected
+
+cmake_minimum_required( VERSION 3.5 )
+
+project( BoostVmdCMakeSelfTest )
+
+add_subdirectory( ../../../preprocessor ${CMAKE_CURRENT_BINARY_DIR}/libs/preprocessor )
+add_subdirectory( ../.. ${CMAKE_CURRENT_BINARY_DIR}/libs/boost_vmd )
+
+add_executable( boost_vmd_cmake_self_test main.cpp )
+target_link_libraries( boost_vmd_cmake_self_test Boost::vmd )
+
diff --git a/src/boost/libs/vmd/test/test_cmake/main.cpp b/src/boost/libs/vmd/test/test_cmake/main.cpp
new file mode 100644
index 000000000..e662c03e5
--- /dev/null
+++ b/src/boost/libs/vmd/test/test_cmake/main.cpp
@@ -0,0 +1,9 @@
+// Use, modification and distribution are subject to the Boost Software License,
+// Version 1.0. (See accompanying file LICENSE_1_0.txt or copy at
+// http://www.boost.org/LICENSE_1_0.txt).
+
+#include <boost/vmd/vmd.hpp>
+
+int main() {
+
+}