summaryrefslogtreecommitdiffstats
path: root/src/cls/cmpomap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/cls/cmpomap/CMakeLists.txt')
-rw-r--r--src/cls/cmpomap/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/cls/cmpomap/CMakeLists.txt b/src/cls/cmpomap/CMakeLists.txt
new file mode 100644
index 000000000..de8ca278c
--- /dev/null
+++ b/src/cls/cmpomap/CMakeLists.txt
@@ -0,0 +1,9 @@
+add_library(cls_cmpomap SHARED server.cc)
+set_target_properties(cls_cmpomap PROPERTIES
+ VERSION "1.0.0"
+ SOVERSION "1"
+ INSTALL_RPATH ""
+ CXX_VISIBILITY_PRESET hidden)
+install(TARGETS cls_cmpomap DESTINATION ${cls_dir})
+
+add_library(cls_cmpomap_client STATIC client.cc)