summaryrefslogtreecommitdiffstats
path: root/src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile.nmake
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile.nmake')
-rw-r--r--src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile.nmake58
1 files changed, 58 insertions, 0 deletions
diff --git a/src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile.nmake b/src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile.nmake
new file mode 100644
index 000000000..daaf04e79
--- /dev/null
+++ b/src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile.nmake
@@ -0,0 +1,58 @@
+########################################################################
+# Copyright(c) 2011-2017 Intel Corporation All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+########################################################################
+
+tests = md5_mb_over_4GB_test.exe sha1_mb_over_4GB_test.exe \
+sha256_mb_over_4GB_test.exe sha512_mb_over_4GB_test.exe
+
+INCLUDES = -I../../include
+LINKFLAGS = /nologo
+INCLUDES = $(INCLUDES) -Ic:\OpenSSL-Win64\include
+CFLAGS = -O2 -D NDEBUG /nologo -D_USE_MATH_DEFINES -Qstd=c99 $(INCLUDES) /c
+LINKFLAGS = $(LINKFLAGS) /libpath:c:\OpenSSL-Win64\lib
+LIBS = ../../isa-l_crypto.lib
+DLL = isa-l_crypto.dll
+
+tests: lib $(tests)
+$(tests): $(@B).obj
+ link /out:$@ $(LINKFLAGS) libeay32.lib $(LIBS) $*.obj
+%.obj: %.c
+ $(CC) $(CFLAGS) -Fo$@ $?
+
+lib:
+ cd ../../ && nmake -f Makefile.nmake
+ cd ../../ && copy $(DLL) "tests\extended"
+
+test: $(tests)
+ !$?
+ echo ALL PASS
+
+clean:
+ -if exist *.obj del *.obj
+ -if exist *.exe del *.exe
+ -if exist *.dll del *.dll