summaryrefslogtreecommitdiffstats
path: root/src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile')
-rw-r--r--src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile b/src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile
new file mode 100644
index 000000000..964baee11
--- /dev/null
+++ b/src/crypto/isa-l/isa-l_crypto/tests/extended/Makefile
@@ -0,0 +1,19 @@
+CFLAGS += -I ../../include
+libs += ../../bin/isa-l_crypto.a
+tests = $(patsubst %test.c, %test, $(wildcard *_test.c))
+
+tests: $(tests)
+$(tests): $(libs)
+%test: %test.c
+ $(CC) $< $(libs) $(CFLAGS) $(LDLIBS) -o $@
+$(libs):
+ $(MAKE) -C ../../ -f Makefile.unx
+test: $(addsuffix .run,$(tests))
+ @echo ALL PASS
+$(addsuffix .run,$(tests)): %.run: %
+ $(SIM) ./$<
+ @echo Completed run: $<
+clean:
+ $(RM) *.o $(tests)
+
+$(tests): LDLIBS += -lcrypto