summaryrefslogtreecommitdiffstats
path: root/src/fmt/test/add-subdirectory-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/fmt/test/add-subdirectory-test/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/fmt/test/add-subdirectory-test/CMakeLists.txt b/src/fmt/test/add-subdirectory-test/CMakeLists.txt
new file mode 100644
index 000000000..e08d0cf70
--- /dev/null
+++ b/src/fmt/test/add-subdirectory-test/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.1...3.18)
+
+project(fmt-test CXX)
+
+add_subdirectory(../.. fmt)
+
+add_executable(library-test main.cc)
+target_include_directories(library-test PUBLIC SYSTEM .)
+target_compile_options(library-test PRIVATE ${PEDANTIC_COMPILE_FLAGS})
+target_link_libraries(library-test fmt::fmt)
+
+if (TARGET fmt::fmt-header-only)
+ add_executable(header-only-test main.cc)
+ target_include_directories(header-only-test PUBLIC SYSTEM .)
+ target_compile_options(header-only-test PRIVATE ${PEDANTIC_COMPILE_FLAGS})
+ target_link_libraries(header-only-test fmt::fmt-header-only)
+endif ()