summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/ampl-asl/fix-crt-linkage.patch
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/ampl-asl/fix-crt-linkage.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/ampl-asl/fix-crt-linkage.patch b/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/ampl-asl/fix-crt-linkage.patch
new file mode 100644
index 000000000..0e29b6ef4
--- /dev/null
+++ b/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/ampl-asl/fix-crt-linkage.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 976af78..35d248d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -256,7 +256,7 @@ macro(createSingleASL name sourcedir sources)
+ endif()
+ if(MSVC)
+ target_compile_options(${name} PRIVATE
+- /wd4013 /wd4018 /wd4101 /wd4244 /wd4273 /wd4267 /wd4996 /MT$<$<CONFIG:Debug>:d>)
++ /wd4013 /wd4018 /wd4101 /wd4244 /wd4273 /wd4267 /wd4996)
+ else()
+ target_compile_options(${name} PRIVATE -Wno-unused-result -Wno-parentheses)
+ endif()