summaryrefslogtreecommitdiffstats
path: root/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/curl/0006_fix_tool_depends.patch
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/curl/0006_fix_tool_depends.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/curl/0006_fix_tool_depends.patch b/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/curl/0006_fix_tool_depends.patch
new file mode 100644
index 000000000..a918b08e2
--- /dev/null
+++ b/src/jaegertracing/opentelemetry-cpp/tools/vcpkg/ports/curl/0006_fix_tool_depends.patch
@@ -0,0 +1,22 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 26e3cfe..74d00dd 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -61,6 +61,8 @@ if(MSVC)
+ list(APPEND CURL_FILES curl.rc)
+ endif()
+
++find_package(ZLIB REQUIRED)
++
+ # CURL_FILES comes from Makefile.inc
+ add_executable(
+ ${EXE_NAME}
+@@ -91,7 +93,7 @@ include_directories(
+ )
+
+ #Build curl executable
+-target_link_libraries(${EXE_NAME} libcurl ${CURL_LIBS})
++target_link_libraries(${EXE_NAME} libcurl ${CURL_LIBS} ZLIB::ZLIB)
+
+ ################################################################################
+