summaryrefslogtreecommitdiffstats
path: root/src/kv/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/kv/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/kv/CMakeLists.txt b/src/kv/CMakeLists.txt
new file mode 100644
index 000000000..9121a6257
--- /dev/null
+++ b/src/kv/CMakeLists.txt
@@ -0,0 +1,13 @@
+set(kv_srcs
+ KeyValueDB.cc
+ RocksDBStore.cc
+ KeyValueHistogram.cc
+ rocksdb_cache/ShardedCache.cc
+ rocksdb_cache/BinnedLRUCache.cc)
+
+add_library(kv STATIC ${kv_srcs}
+ $<TARGET_OBJECTS:common_prioritycache_obj>)
+
+target_link_libraries(kv
+ RocksDB::RocksDB
+ heap_profiler)