summaryrefslogtreecommitdiffstats
path: root/src/pybind/mgr/dashboard/frontend/package.json
diff options
context:
space:
mode:
Diffstat (limited to 'src/pybind/mgr/dashboard/frontend/package.json')
-rw-r--r--src/pybind/mgr/dashboard/frontend/package.json137
1 files changed, 137 insertions, 0 deletions
diff --git a/src/pybind/mgr/dashboard/frontend/package.json b/src/pybind/mgr/dashboard/frontend/package.json
new file mode 100644
index 000000000..3205888f5
--- /dev/null
+++ b/src/pybind/mgr/dashboard/frontend/package.json
@@ -0,0 +1,137 @@
+{
+ "name": "ceph-dashboard",
+ "version": "0.0.0",
+ "license": "MIT",
+ "config": {
+ "locale": "en-US"
+ },
+ "scripts": {
+ "ng": "ng",
+ "start": "npm run env_build && ng serve --host 0.0.0.0 --ssl",
+ "build": "npm run env_build && ng build --configuration=$npm_package_config_locale",
+ "build:localize": "node cd --env --pre && ng build --localize",
+ "postbuild:localize": "node cd --res",
+ "env_build": "node cd --env",
+ "i18n": "npm run i18n:extract && npm run i18n:push && npm run i18n:pull && npm run i18n:merge",
+ "i18n:extract": "ng extract-i18n --output-path src/locale --progress=false",
+ "i18n:push": "npx i18ntool push -c i18n.config.json",
+ "i18n:pull": "npx i18ntool pull -c i18n.config.json",
+ "i18n:merge": "npx i18ntool merge -c i18n.config.json",
+ "i18n:token": "npx i18ntool config token",
+ "test": "jest --watch",
+ "test:ci": "jest --clearCache && JEST_SILENT_REPORTER_DOTS=true jest --coverage --reporters jest-silent-reporter",
+ "pree2e": "rm -f cypress/reports/results-*.xml || true",
+ "e2e": "start-test 4200 'cypress open'",
+ "pree2e:ci": "npm run pree2e",
+ "e2e:ci": "start-test 4200 'cypress run -b chrome --headless'",
+ "lint:eslint": "ng lint",
+ "lint:gherkin": "gherkin-lint -c .gherkin-lintrc cypress/e2e",
+ "lint:prettier": "prettier --list-different \"{src,cypress}/**/*.{ts,scss}\"",
+ "lint:html": "htmllint src/app/**/*.html && html-linter --config html-linter.config.json",
+ "prelint:tsc": "npm run postinstall",
+ "lint:tsc": "tsc -p tsconfig.app.json --noEmit && tsc -p tsconfig.spec.json --noEmit && tsc -p cypress/tsconfig.json --noEmit",
+ "lint:scss": "stylelint '**/*.scss'",
+ "lint": "run-p -csl --aggregate-output lint:*",
+ "fix:prettier": "prettier --write \"{src,cypress}/**/*.{ts,scss}\"",
+ "fix:eslint": "npm run lint:eslint -- --fix",
+ "fix:scss": "stylelint '**/*.scss' --fix",
+ "fixmod": "pretty-quick --pattern \"{src,cypress}/**/*.{ts,scss}\" --branch HEAD",
+ "fix": "run-p -csl --aggregate-output fix:*",
+ "compodoc": "compodoc",
+ "doc-build": "compodoc -p tsconfig.app.json",
+ "doc-serve": "compodoc --port 8444 -s tsconfig.app.json",
+ "postinstall": "ngcc --properties es2015 browser module main --async false --first-only --tsconfig 'tsconfig.app.json'"
+ },
+ "private": true,
+ "dependencies": {
+ "@angular/animations": "15.2.9",
+ "@angular/common": "15.2.9",
+ "@angular/compiler": "15.2.9",
+ "@angular/core": "15.2.9",
+ "@angular/forms": "15.2.9",
+ "@angular/localize": "15.2.9",
+ "@angular/platform-browser": "15.2.9",
+ "@angular/platform-browser-dynamic": "15.2.9",
+ "@angular/router": "15.2.9",
+ "@circlon/angular-tree-component": "10.0.0",
+ "@ng-bootstrap/ng-bootstrap": "14.2.0",
+ "@ngx-formly/bootstrap": "6.1.1",
+ "@ngx-formly/core": "6.1.1",
+ "@popperjs/core": "2.10.2",
+ "@swimlane/ngx-datatable": "18.0.0",
+ "@types/file-saver": "2.0.1",
+ "async-mutex": "0.2.4",
+ "bootstrap": "5.2.3",
+ "chart.js": "2.9.4",
+ "detect-browser": "5.2.0",
+ "file-saver": "2.0.2",
+ "fork-awesome": "1.1.7",
+ "lodash": "4.17.21",
+ "moment": "2.29.4",
+ "ng-block-ui": "3.0.2",
+ "ng-click-outside": "7.0.0",
+ "ng2-charts": "2.4.2",
+ "ngx-pipe-function": "1.0.0",
+ "ngx-toastr": "17.0.2",
+ "rxjs": "6.6.3",
+ "simplebar-angular": "2.3.6",
+ "swagger-ui": "4.12.0",
+ "tslib": "2.3.1",
+ "zone.js": "0.11.8"
+ },
+ "devDependencies": {
+ "@angular-devkit/build-angular": "15.2.9",
+ "@angular-eslint/builder": "13.5.0",
+ "@angular-eslint/eslint-plugin": "13.5.0",
+ "@angular-eslint/eslint-plugin-template": "13.5.0",
+ "@angular-eslint/schematics": "13.5.0",
+ "@angular-eslint/template-parser": "13.5.0",
+ "@angular/cli": "15.2.9",
+ "@angular/compiler-cli": "15.2.9",
+ "@angular/language-service": "15.2.9",
+ "@applitools/eyes-cypress": "3.22.5",
+ "@compodoc/compodoc": "1.1.18",
+ "@cypress/browserify-preprocessor": "3.0.2",
+ "@types/brace-expansion": "1.1.0",
+ "@types/cypress-cucumber-preprocessor": "4.0.1",
+ "@types/jest": "29.5.4",
+ "@types/lodash": "4.14.161",
+ "@types/node": "18.17.12",
+ "@types/swagger-ui": "3.52.0",
+ "@typescript-eslint/eslint-plugin": "5.27.1",
+ "@typescript-eslint/parser": "5.27.1",
+ "axe-core": "4.4.3",
+ "cypress": "12.17.4",
+ "cypress-axe": "1.5.0",
+ "cypress-cucumber-preprocessor": "4.3.1",
+ "cypress-iframe": "1.0.1",
+ "cypress-multi-reporters": "1.5.0",
+ "eslint": "8.17.0",
+ "gherkin-lint": "4.2.2",
+ "html-linter": "1.1.1",
+ "htmllint-cli": "0.0.7",
+ "identity-obj-proxy": "3.0.0",
+ "isomorphic-form-data": "2.0.0",
+ "jest": "29.6.4",
+ "jest-canvas-mock": "2.4.0",
+ "jest-jasmine2": "28.1.3",
+ "jest-preset-angular": "13.1.1",
+ "jest-silent-reporter": "0.5.0",
+ "mocha-junit-reporter": "2.1.0",
+ "ng-mocks": "14.3.0",
+ "npm-run-all": "4.1.5",
+ "prettier": "2.1.2",
+ "pretty-quick": "3.0.2",
+ "start-server-and-test": "1.12.1",
+ "stylelint": "13.13.1",
+ "stylelint-config-sass-guidelines": "7.1.0",
+ "stylelint-declaration-use-variable": "1.7.3",
+ "table": "6.8.0",
+ "transifex-i18ntool": "1.1.0",
+ "ts-node": "9.0.0",
+ "typescript": "4.9.5"
+ },
+ "cypress-cucumber-preprocessor": {
+ "stepDefinitions": "cypress/e2e/common"
+ }
+}