summaryrefslogtreecommitdiffstats
path: root/src/pybind/rgw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/pybind/rgw/CMakeLists.txt')
-rw-r--r--src/pybind/rgw/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/pybind/rgw/CMakeLists.txt b/src/pybind/rgw/CMakeLists.txt
new file mode 100644
index 000000000..5b1a955c5
--- /dev/null
+++ b/src/pybind/rgw/CMakeLists.txt
@@ -0,0 +1,6 @@
+distutils_add_cython_module(cython${PYTHON_VERSION}_rgw
+ rgw
+ ${CMAKE_CURRENT_SOURCE_DIR}/rgw.pyx)
+add_dependencies(cython${PYTHON_VERSION}_rgw rgw)
+distutils_install_cython_module(cython${PYTHON_VERSION}_rgw
+ ${PYTHON_VERSION})