summaryrefslogtreecommitdiffstats
path: root/src/spawn/test/dependency/googletest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/spawn/test/dependency/googletest/CMakeLists.txt')
-rw-r--r--src/spawn/test/dependency/googletest/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/spawn/test/dependency/googletest/CMakeLists.txt b/src/spawn/test/dependency/googletest/CMakeLists.txt
new file mode 100644
index 000000000..3fae2f965
--- /dev/null
+++ b/src/spawn/test/dependency/googletest/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Note: CMake support is community-based. The maintainers do not use CMake
+# internally.
+
+cmake_minimum_required(VERSION 2.8.8)
+
+if (POLICY CMP0048)
+ cmake_policy(SET CMP0048 NEW)
+endif (POLICY CMP0048)
+
+project(googletest-distribution)
+set(GOOGLETEST_VERSION 1.9.0)
+
+if (CMAKE_VERSION VERSION_LESS "3.1")
+ add_definitions(-std=c++11)
+else()
+ set(CMAKE_CXX_STANDARD 11)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+ if(NOT CYGWIN)
+ set(CMAKE_CXX_EXTENSIONS OFF)
+ endif()
+endif()
+
+enable_testing()
+
+include(CMakeDependentOption)
+include(GNUInstallDirs)
+
+#Note that googlemock target already builds googletest
+option(BUILD_GMOCK "Builds the googlemock subproject" ON)
+option(INSTALL_GTEST "Enable installation of googletest. (Projects embedding googletest may want to turn this OFF.)" ON)
+
+if(BUILD_GMOCK)
+ add_subdirectory( googlemock )
+else()
+ add_subdirectory( googletest )
+endif()