summaryrefslogtreecommitdiffstats
path: root/debian/patches/0009-resolvelib_compat.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:05:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:05:49 +0000
commit7d5405ffc51866bb1570224060224121eed09f11 (patch)
tree848235f8834aa2e2f71666410a429441dc437f5b /debian/patches/0009-resolvelib_compat.patch
parentAdding upstream version 2.14.13. (diff)
downloadansible-core-7d5405ffc51866bb1570224060224121eed09f11.tar.xz
ansible-core-7d5405ffc51866bb1570224060224121eed09f11.zip
Adding debian version 2.14.13-1.debian/2.14.13-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/0009-resolvelib_compat.patch')
-rw-r--r--debian/patches/0009-resolvelib_compat.patch113
1 files changed, 113 insertions, 0 deletions
diff --git a/debian/patches/0009-resolvelib_compat.patch b/debian/patches/0009-resolvelib_compat.patch
new file mode 100644
index 0000000..7a633cd
--- /dev/null
+++ b/debian/patches/0009-resolvelib_compat.patch
@@ -0,0 +1,113 @@
+Description: ansible-galaxy - support resolvelib >= 0.5.3, < 1.1.0
+Author: Wong Hoi Sing Edison <hswong3i@gmail.com>
+Origin: upstream, https://github.com/ansible/ansible/pull/80196
+Applied-Upstream: yes
+Forwarded: not-needed
+Reviewed-by: Lee Garrett <debian@rocketjump.eu>
+Last-Update: 2023-10-23
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- /dev/null
++++ b/changelogs/fragments/79399-resolvelib_lt_0_10_0.yml
+@@ -0,0 +1,2 @@
++minor_changes:
++ - ansible-galaxy - support ``resolvelib >= 0.5.3, < 1.1.0``.
+--- a/lib/ansible/galaxy/dependency_resolution/providers.py
++++ b/lib/ansible/galaxy/dependency_resolution/providers.py
+@@ -40,7 +40,7 @@
+
+ # TODO: add python requirements to ansible-test's ansible-core distribution info and remove the hardcoded lowerbound/upperbound fallback
+ RESOLVELIB_LOWERBOUND = SemanticVersion("0.5.3")
+-RESOLVELIB_UPPERBOUND = SemanticVersion("0.9.0")
++RESOLVELIB_UPPERBOUND = SemanticVersion("1.1.0")
+ RESOLVELIB_VERSION = SemanticVersion.from_loose_version(LooseVersion(resolvelib_version))
+
+
+@@ -190,7 +190,7 @@
+ Mapping of identifier, list of named tuple pairs.
+ The named tuples have the entries ``requirement`` and ``parent``.
+
+- resolvelib >=0.8.0, <= 0.8.1
++ resolvelib >=0.8.0, <= 1.0.1
+
+ :param identifier: The value returned by ``identify()``.
+
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -12,4 +12,4 @@
+ # NOTE: Ref: https://github.com/sarugaku/resolvelib/issues/69
+ # NOTE: When updating the upper bound, also update the latest version used
+ # NOTE: in the ansible-galaxy-collection test suite.
+-resolvelib >= 0.5.3, < 0.9.0 # dependency resolver used by ansible-galaxy
++resolvelib >= 0.5.3, < 1.1.0 # dependency resolver used by ansible-galaxy
+--- a/test/lib/ansible_test/_data/requirements/ansible.txt
++++ b/test/lib/ansible_test/_data/requirements/ansible.txt
+@@ -12,4 +12,4 @@
+ # NOTE: Ref: https://github.com/sarugaku/resolvelib/issues/69
+ # NOTE: When updating the upper bound, also update the latest version used
+ # NOTE: in the ansible-galaxy-collection test suite.
+-resolvelib >= 0.5.3, < 0.9.0 # dependency resolver used by ansible-galaxy
++resolvelib >= 0.5.3, < 1.1.0 # dependency resolver used by ansible-galaxy
+--- a/test/sanity/code-smell/package-data.requirements.in
++++ b/test/sanity/code-smell/package-data.requirements.in
+@@ -2,7 +2,7 @@
+ wheel # required to build wheel
+ jinja2
+ pyyaml # ansible-core requirement
+-resolvelib < 0.9.0
++resolvelib < 1.1.0
+ rstcheck < 4 # match version used in other sanity tests
+ antsibull-changelog
+ setuptools == 45.2.0 # minimum supported setuptools
+--- a/test/sanity/code-smell/package-data.requirements.txt
++++ b/test/sanity/code-smell/package-data.requirements.txt
+@@ -10,7 +10,7 @@
+ pyproject_hooks==1.0.0
+ pyparsing==3.0.9
+ PyYAML==6.0
+-resolvelib==0.8.1
++resolvelib==1.0.1
+ rstcheck==3.5.0
+ semantic-version==2.10.0
+ setuptools==45.2.0
+--- a/lib/ansible_core.egg-info/requires.txt
++++ b/lib/ansible_core.egg-info/requires.txt
+@@ -2,4 +2,4 @@
+ PyYAML>=5.1
+ cryptography
+ packaging
+-resolvelib<0.9.0,>=0.5.3
++resolvelib<1.1.0,>=0.5.3
+--- a/test/integration/targets/ansible-galaxy-collection/vars/main.yml
++++ b/test/integration/targets/ansible-galaxy-collection/vars/main.yml
+@@ -9,6 +9,8 @@
+ - "0.6.0"
+ - "0.7.0"
+ - "0.8.0"
++ - "0.9.0"
++ - "1.0.1"
+
+ unsupported_resolvelib_versions:
+ - "0.2.0" # Fails on import
+--- a/PKG-INFO
++++ b/PKG-INFO
+@@ -35,7 +35,7 @@
+ Requires-Dist: PyYAML>=5.1
+ Requires-Dist: cryptography
+ Requires-Dist: packaging
+-Requires-Dist: resolvelib<0.9.0,>=0.5.3
++Requires-Dist: resolvelib<1.1.0,>=0.5.3
+
+ [![PyPI version](https://img.shields.io/pypi/v/ansible-core.svg)](https://pypi.org/project/ansible-core)
+ [![Docs badge](https://img.shields.io/badge/docs-latest-brightgreen.svg)](https://docs.ansible.com/ansible/latest/)
+--- a/lib/ansible_core.egg-info/PKG-INFO
++++ b/lib/ansible_core.egg-info/PKG-INFO
+@@ -35,7 +35,7 @@
+ Requires-Dist: PyYAML>=5.1
+ Requires-Dist: cryptography
+ Requires-Dist: packaging
+-Requires-Dist: resolvelib<0.9.0,>=0.5.3
++Requires-Dist: resolvelib<1.1.0,>=0.5.3
+
+ [![PyPI version](https://img.shields.io/pypi/v/ansible-core.svg)](https://pypi.org/project/ansible-core)
+ [![Docs badge](https://img.shields.io/badge/docs-latest-brightgreen.svg)](https://docs.ansible.com/ansible/latest/)