summaryrefslogtreecommitdiffstats
path: root/.packit.yaml
diff options
context:
space:
mode:
Diffstat (limited to '.packit.yaml')
-rw-r--r--.packit.yaml44
1 files changed, 44 insertions, 0 deletions
diff --git a/.packit.yaml b/.packit.yaml
new file mode 100644
index 0000000..546b7fe
--- /dev/null
+++ b/.packit.yaml
@@ -0,0 +1,44 @@
+---
+# spell-checker:ignore packit specfile copr epel
+specfile_path: dist/ansible-lint.spec
+actions:
+ create-archive:
+ # packit.dev service does have these module pre-installed:
+ - python3 -m build --sdist --outdir dist
+ - sh -c "ls dist/ansible-lint-*.tar.gz"
+ get-current-version:
+ - ./tools/get-version.sh
+ post-upstream-clone:
+ - "git submodule init"
+ - "git submodule update"
+ - ./tools/update-version.sh
+srpm_build_deps:
+ - python3-build
+ - python3-setuptools_scm
+jobs:
+ # - job: copr_build
+ # targets:
+ # - fedora-rawhide-aarch64 # one on PR should be enough
+ # trigger: pull_request
+ - job: copr_build
+ trigger: commit
+ branch: main
+ targets:
+ # See https://packit.dev/docs/configuration/#aliases
+ # API to get available targets: https://api.dev.testing-farm.io/v0.1/composes/public
+ - fedora-rawhide-x86_64
+ - fedora-rawhide-aarch64
+ - fedora-37-x86_64
+ - fedora-37-aarch64
+ # Missing python3-build see https://bugzilla.redhat.com/show_bug.cgi?id=2129071
+ # - centos-stream-9-aarch64
+ # - centos-stream-9-x86_64
+ # - job: tests
+ # trigger: pull_request
+ # metadata:
+ # targets:
+ # - fedora-all
+ # - job: propose_downstream
+ # trigger: release
+ # metadata:
+ # dist-git-branch: master