summaryrefslogtreecommitdiffstats
path: root/ansible_collections/cisco/meraki/docs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-18 05:52:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-18 05:52:35 +0000
commit7fec0b69a082aaeec72fee0612766aa42f6b1b4d (patch)
treeefb569b86ca4da888717f5433e757145fa322e08 /ansible_collections/cisco/meraki/docs
parentReleasing progress-linux version 7.7.0+dfsg-3~progress7.99u1. (diff)
downloadansible-7fec0b69a082aaeec72fee0612766aa42f6b1b4d.tar.xz
ansible-7fec0b69a082aaeec72fee0612766aa42f6b1b4d.zip
Merging upstream version 9.4.0+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ansible_collections/cisco/meraki/docs')
-rw-r--r--ansible_collections/cisco/meraki/docs/Makefile20
-rw-r--r--ansible_collections/cisco/meraki/docs/_gh_include/footer.inc4
-rw-r--r--ansible_collections/cisco/meraki/docs/_gh_include/header.inc18
-rw-r--r--ansible_collections/cisco/meraki/docs/conf.py155
-rw-r--r--ansible_collections/cisco/meraki/docs/index.rst21
-rw-r--r--ansible_collections/cisco/meraki/docs/platform_meraki.rst71
-rw-r--r--ansible_collections/cisco/meraki/docs/requirements.txt6
7 files changed, 295 insertions, 0 deletions
diff --git a/ansible_collections/cisco/meraki/docs/Makefile b/ansible_collections/cisco/meraki/docs/Makefile
new file mode 100644
index 000000000..210c47393
--- /dev/null
+++ b/ansible_collections/cisco/meraki/docs/Makefile
@@ -0,0 +1,20 @@
+# Minimal makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS =
+SPHINXBUILD = sphinx-build
+SPHINXPROJ = MerakiAnsibleActions
+SOURCEDIR = .
+BUILDDIR = _build
+
+# Put it first so that "make" without argument is like "make help".
+help:
+ @$(SPHINXBUILD) -M help "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+
+.PHONY: help Makefile
+
+# Catch-all target: route all unknown targets to Sphinx using the new
+# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).
+%: Makefile
+ @$(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
diff --git a/ansible_collections/cisco/meraki/docs/_gh_include/footer.inc b/ansible_collections/cisco/meraki/docs/_gh_include/footer.inc
new file mode 100644
index 000000000..deddeb6c8
--- /dev/null
+++ b/ansible_collections/cisco/meraki/docs/_gh_include/footer.inc
@@ -0,0 +1,4 @@
+ </div>
+
+ </body>
+</html>
diff --git a/ansible_collections/cisco/meraki/docs/_gh_include/header.inc b/ansible_collections/cisco/meraki/docs/_gh_include/header.inc
new file mode 100644
index 000000000..cb33a45f4
--- /dev/null
+++ b/ansible_collections/cisco/meraki/docs/_gh_include/header.inc
@@ -0,0 +1,18 @@
+<!doctype html>
+<html>
+ <head>
+ <title>Meraki Ansible Actions documentation index</title>
+ <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
+ <link rel="stylesheet" media="all" href="https://theforeman.org/static/css/bootstrap.min.css"/>
+ <link rel="stylesheet" media="all" href="https://theforeman.org/static/css/bootstrap-responsive.min.css"/>
+ <link rel="stylesheet" media="all" href="https://theforeman.org/static/css/style.css"/>
+ <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">
+ <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.4/jquery.min.js"></script>
+ </head>
+
+ <body style="margin:0px 15px">
+ <h1>Meraki Ansible Actions</h1>
+
+ <hr />
+
+ <div class="row plugin-manual">
diff --git a/ansible_collections/cisco/meraki/docs/conf.py b/ansible_collections/cisco/meraki/docs/conf.py
new file mode 100644
index 000000000..521a8edce
--- /dev/null
+++ b/ansible_collections/cisco/meraki/docs/conf.py
@@ -0,0 +1,155 @@
+# -*- coding: utf-8 -*-
+from __future__ import (absolute_import, division, print_function)
+__metaclass__ = type
+
+#
+# Configuration file for the Sphinx documentation builder.
+#
+# This file does only contain a selection of the most common options. For a
+# full list see the documentation:
+# http://www.sphinx-doc.org/en/master/config
+
+# -- Path setup --------------------------------------------------------------
+
+# If extensions (or modules to document with autodoc) are in another directory,
+# add these directories to sys.path here. If the directory is relative to the
+# documentation root, use os.path.abspath to make it absolute, like shown here.
+#
+import os
+import sys
+sys.path.insert(0, os.path.abspath('../plugins/plugin_utils/'))
+# sys.path.insert(0, os.path.abspath('.'))
+
+# -- Project information -----------------------------------------------------
+
+project = 'MerakiAnsibleActions'
+copyright = u'Copyright (c) 2021 Cisco Systems'
+author = u''
+
+# The short X.Y version
+version = ''
+# The full version, including alpha/beta/rc tags
+release = ''
+
+# -- General configuration ---------------------------------------------------
+
+# If your documentation needs a minimal Sphinx version, state it here.
+#
+# needs_sphinx = '1.0'
+
+# Add any Sphinx extension module names here, as strings. They can be
+# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
+# ones.
+extensions = [
+ 'recommonmark',
+ 'sphinx.ext.autodoc',
+ 'sphinx.ext.intersphinx',
+ 'ansible_basic_sphinx_ext',
+]
+
+# Add any paths that contain templates here, relative to this directory.
+templates_path = ['_templates']
+
+# The suffix(es) of source filenames.
+# You can specify multiple suffix as a list of string:
+#
+# source_suffix = ['.rst', '.md']
+source_suffix = {
+ '.rst': 'restructuredtext',
+ '.md': 'markdown',
+}
+
+# The master toctree document.
+master_doc = 'index'
+
+smartquotes = False
+
+# The language for content autogenerated by Sphinx. Refer to documentation
+# for a list of supported languages.
+#
+# This is also used if you do content translation via gettext catalogs.
+# Usually you set "language" from the command line for these cases.
+language = None
+
+# List of patterns, relative to source directory, that match files and
+# directories to ignore when looking for source files.
+# This pattern also affects html_static_path and html_extra_path .
+exclude_patterns = ['_build', 'Thumbs.db', '.DS_Store', '.tmp']
+
+# The name of the Pygments (syntax highlighting) style to use.
+pygments_style = 'sphinx'
+
+highlight_language = 'YAML+Jinja'
+
+# -- Options for HTML output -------------------------------------------------
+html_theme_path = ['_themes']
+# The theme to use for HTML and HTML Help pages. See the documentation for
+# a list of builtin themes.
+#
+# html_theme = 'alabaster'
+html_theme = 'sphinx_rtd_theme'
+
+# Theme options are theme-specific and customize the look and feel of a theme
+# further. For a list of options available for each theme, see the
+# documentation.
+#
+# html_theme_options = {}
+
+# Add any paths that contain custom static files (such as style sheets) here,
+# relative to this directory. They are copied after the builtin static files,
+# so a file named "default.css" will overwrite the builtin "default.css".
+html_static_path = []
+
+# Custom sidebar templates, must be a dictionary that maps document names
+# to template names.
+#
+# The default sidebars (for documents that don't match any pattern) are
+# defined by theme itself. Builtin themes are using these templates by
+# default: ``['localtoc.html', 'relations.html', 'sourcelink.html',
+# 'searchbox.html']``.
+#
+# html_sidebars = {}
+
+# -- Options for HTMLHelp output ---------------------------------------------
+
+# Output file base name for HTML help builder.
+htmlhelp_basename = 'MerakiAnsibleActionsdoc'
+
+# -- Options for LaTeX output ------------------------------------------------
+
+latex_elements = {}
+
+# Grouping the document tree into LaTeX files. List of tuples
+# (source start file, target name, title,
+# author, documentclass [howto, manual, or own class]).
+latex_documents = [
+ (master_doc, 'MerakiAnsibleActions.tex', 'MerakiAnsibleActions Documentation',
+ 'The DNA Center Project', 'manual'),
+]
+
+# -- Options for manual page output ------------------------------------------
+
+# One entry per manual page. List of tuples
+# (source start file, name, description, authors, manual section).
+man_pages = [
+ (master_doc, 'MerakiAnsibleActions', 'MerakiAnsibleActions Documentation',
+ [author], 1)
+]
+
+# -- Options for Texinfo output ----------------------------------------------
+
+# Grouping the document tree into Texinfo files. List of tuples
+# (source start file, target name, title, author,
+# dir menu entry, description, category)
+texinfo_documents = [
+ (master_doc, 'MerakiAnsibleActions', 'MerakiAnsibleActions Documentation',
+ author, 'MerakiAnsibleActions', 'One line description of project.',
+ 'Miscellaneous'),
+]
+
+# -- Extension configuration -------------------------------------------------
+
+# -- Options for intersphinx extension ---------------------------------------
+
+# Example configuration for intersphinx: refer to the Python standard library.
+intersphinx_mapping = {'python': ('https://docs.python.org/2', None), 'ansible': ('https://docs.ansible.com/ansible/latest/', None)}
diff --git a/ansible_collections/cisco/meraki/docs/index.rst b/ansible_collections/cisco/meraki/docs/index.rst
new file mode 100644
index 000000000..3793ffcc2
--- /dev/null
+++ b/ansible_collections/cisco/meraki/docs/index.rst
@@ -0,0 +1,21 @@
+.. DNA Center Ansible Actions documentation main file, created by
+ sphinx-quickstart on Tue Dec 12 10:00:39 2018.
+ You can adapt this file completely to your liking, but it should at least
+ contain the root `toctree` directive.
+
+Welcome to Meraki Ansible Actions documentation!
+=====================================================
+
+.. toctree::
+ :maxdepth: 2
+ :caption: User documentation
+
+ plugins/index
+ platform_meraki
+
+
+Indices and tables
+==================
+
+* :ref:`genindex`
+* :ref:`search`
diff --git a/ansible_collections/cisco/meraki/docs/platform_meraki.rst b/ansible_collections/cisco/meraki/docs/platform_meraki.rst
new file mode 100644
index 000000000..4ec1c37f0
--- /dev/null
+++ b/ansible_collections/cisco/meraki/docs/platform_meraki.rst
@@ -0,0 +1,71 @@
+.. _meraki_platform_options:
+
+***************************************
+Meraki Platform Options
+***************************************
+
+The `cisco.meraki <https://galaxy.ansible.com/ui/repo/published/cisco/meraki>`_ collection only supports the ``local`` connection type at this time.
+
+.. contents::
+ :local:
+
+Connections available
+================================================================================
+
+.. table::
+ :class: documentation-table
+
+ ==================== ==========================================
+ .. Dashboard API
+ ==================== ==========================================
+ Protocol HTTP(S)
+
+ Credentials uses API key from Dashboard
+
+ Connection Settings ``ansible_connection: localhost``
+
+ Returned Data Format ``data.``
+ ==================== ==========================================
+
+
+Example Meraki task
+-------------------
+
+.. code-block:: yaml
+
+ cisco.meraki.meraki_organization:
+ auth_key: abc12345
+ org_name: YourOrg
+ state: present
+ delegate_to: localhost
+
+For modules that do not have the "meraki" prefix, this is an example that you can use as a guide
+
+.. code-block:: yaml
+
+ cisco.meraki.administered_identities_me_info:
+ meraki_api_key: "{{meraki_api_key}}"
+ meraki_base_url: "{{meraki_base_url}}"
+ meraki_single_request_timeout: "{{meraki_single_request_timeout}}"
+ meraki_certificate_path: "{{meraki_certificate_path}}"
+ meraki_requests_proxy: "{{meraki_requests_proxy}}"
+ meraki_wait_on_rate_limit: "{{meraki_wait_on_rate_limit}}"
+ meraki_nginx_429_retry_wait_time: "{{meraki_nginx_429_retry_wait_time}}"
+ meraki_action_batch_retry_wait_time: "{{meraki_action_batch_retry_wait_time}}"
+ meraki_retry_4xx_error: "{{meraki_retry_4xx_error}}"
+ meraki_retry_4xx_error_wait_time: "{{meraki_retry_4xx_error_wait_time}}"
+ meraki_maximum_retries: "{{meraki_maximum_retries}}"
+ meraki_output_log: "{{meraki_output_log}}"
+ meraki_log_file_prefix: "{{meraki_log_file_prefix}}"
+ meraki_log_path: "{{meraki_log_path}}"
+ meraki_print_console: "{{meraki_print_console}}"
+ meraki_suppress_logging: "{{meraki_suppress_logging}}"
+ meraki_simulate: "{{meraki_simulate}}"
+ meraki_be_geo_id: "{{meraki_be_geo_id}}"
+ meraki_use_iterator_for_get_pages: "{{meraki_use_iterator_for_get_pages}}"
+ meraki_inherit_logging_config: "{{meraki_inherit_logging_config}}"
+ register: result
+
+.. seealso::
+
+ :ref:`timeout_options` \ No newline at end of file
diff --git a/ansible_collections/cisco/meraki/docs/requirements.txt b/ansible_collections/cisco/meraki/docs/requirements.txt
new file mode 100644
index 000000000..74fe21c59
--- /dev/null
+++ b/ansible_collections/cisco/meraki/docs/requirements.txt
@@ -0,0 +1,6 @@
+PyYAML>=5.4.1
+antsibull>=0.17.0
+ansible-base>=2.10.0rc2
+sphinx-rtd-theme
+git+https://github.com/felixfontein/ansible-basic-sphinx-ext
+recommonmark