summaryrefslogtreecommitdiffstats
path: root/ansible_collections/community/okd/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:04:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:04:41 +0000
commit975f66f2eebe9dadba04f275774d4ab83f74cf25 (patch)
tree89bd26a93aaae6a25749145b7e4bca4a1e75b2be /ansible_collections/community/okd/Makefile
parentInitial commit. (diff)
downloadansible-975f66f2eebe9dadba04f275774d4ab83f74cf25.tar.xz
ansible-975f66f2eebe9dadba04f275774d4ab83f74cf25.zip
Adding upstream version 7.7.0+dfsg.upstream/7.7.0+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--ansible_collections/community/okd/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/ansible_collections/community/okd/Makefile b/ansible_collections/community/okd/Makefile
new file mode 100644
index 000000000..7990f8447
--- /dev/null
+++ b/ansible_collections/community/okd/Makefile
@@ -0,0 +1,55 @@
+.PHONY: molecule
+
+# Also needs to be updated in galaxy.yml
+VERSION = 2.3.0
+
+SANITY_TEST_ARGS ?= --docker --color
+UNITS_TEST_ARGS ?= --docker --color
+PYTHON_VERSION ?= `python3 -c 'import platform; print("{0}.{1}".format(platform.python_version_tuple()[0], platform.python_version_tuple()[1]))'`
+
+clean:
+ rm -f community-okd-$(VERSION).tar.gz
+ rm -f redhat-openshift-$(VERSION).tar.gz
+ rm -rf ansible_collections
+
+build: clean
+ ansible-galaxy collection build
+
+install: build
+ ansible-galaxy collection install -p ansible_collections community-okd-$(VERSION).tar.gz
+
+sanity: install
+ cd ansible_collections/community/okd && ansible-test sanity -v --python $(PYTHON_VERSION) $(SANITY_TEST_ARGS)
+
+units: install
+ cd ansible_collections/community/okd && ansible-test units -v --python $(PYTHON_VERSION) $(UNITS_TEST_ARGS)
+
+molecule: install
+ molecule test
+
+test-integration: upstream-test-integration downstream-test-integration
+
+test-sanity: upstream-test-sanity downstream-test-sanity
+
+test-units: upstream-test-units downstream-test-units
+
+test-integration-incluster:
+ ./ci/incluster_integration.sh
+
+upstream-test-sanity: sanity
+
+upstream-test-units: units
+
+upstream-test-integration: molecule
+
+downstream-test-sanity:
+ ./ci/downstream.sh -s
+
+downstream-test-units:
+ ./ci/downstream.sh -u
+
+downstream-test-integration:
+ ./ci/downstream.sh -i
+
+downstream-build:
+ ./ci/downstream.sh -b