summaryrefslogtreecommitdiffstats
path: root/ansible_collections/containers/podman/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:04:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 12:04:41 +0000
commit975f66f2eebe9dadba04f275774d4ab83f74cf25 (patch)
tree89bd26a93aaae6a25749145b7e4bca4a1e75b2be /ansible_collections/containers/podman/Makefile
parentInitial commit. (diff)
downloadansible-975f66f2eebe9dadba04f275774d4ab83f74cf25.tar.xz
ansible-975f66f2eebe9dadba04f275774d4ab83f74cf25.zip
Adding upstream version 7.7.0+dfsg.upstream/7.7.0+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--ansible_collections/containers/podman/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/ansible_collections/containers/podman/Makefile b/ansible_collections/containers/podman/Makefile
new file mode 100644
index 000000000..7dbdd9a6b
--- /dev/null
+++ b/ansible_collections/containers/podman/Makefile
@@ -0,0 +1,15 @@
+PKG_NAME=ansible-podman-collections
+TMPINSTALLDIR=/tmp/$(PKG_NAME)-fpm-install
+VERSION ?= $(shell python3 setup.py --version 2>/dev/null | sed "s/\([0-9]\+\.[0-9]\+\.[0-9]\+\).*/\1/g")
+
+rpm:
+ rm -rf $(TMPINSTALLDIR)
+ mkdir -p ~/rpmbuild/SOURCES/
+ mkdir -p $(TMPINSTALLDIR)/$(PKG_NAME)-$(VERSION)
+ cp -r * $(TMPINSTALLDIR)/$(PKG_NAME)-$(VERSION)/
+ tar -zcvf ~/rpmbuild/SOURCES/$(VERSION).tar.gz -C $(TMPINSTALLDIR) $(PKG_NAME)-$(VERSION)
+ cp ansible-collection-containers-podman.spec ansible-collection-containers-podman-build.spec
+ sed -i "s/Version:.*/Version: $(VERSION)/g" ansible-collection-containers-podman-build.spec
+ sed -i "s/Release:.*/Release: 999%{?dist}/g" ansible-collection-containers-podman-build.spec
+ sed -i "s/^version: .*/version: $(VERSION)/" $(TMPINSTALLDIR)/$(PKG_NAME)-$(VERSION)/galaxy.yml
+ rpmbuild -bb ansible-collection-containers-podman-build.spec