summaryrefslogtreecommitdiffstats
path: root/ansible_collections/hetzner/hcloud/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-05 16:18:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-05 16:18:37 +0000
commit5d7eda1e172f8e396536a8fbd6f85b4b991290e8 (patch)
treeb18be36b43a1abdab0d40ecc8e4c8de2dbcd65c0 /ansible_collections/hetzner/hcloud/Makefile
parentAdding debian version 9.5.1+dfsg-1. (diff)
downloadansible-5d7eda1e172f8e396536a8fbd6f85b4b991290e8.tar.xz
ansible-5d7eda1e172f8e396536a8fbd6f85b4b991290e8.zip
Merging upstream version 10.0.0+dfsg.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ansible_collections/hetzner/hcloud/Makefile')
-rw-r--r--ansible_collections/hetzner/hcloud/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/ansible_collections/hetzner/hcloud/Makefile b/ansible_collections/hetzner/hcloud/Makefile
index 48c411d64..12a2521ea 100644
--- a/ansible_collections/hetzner/hcloud/Makefile
+++ b/ansible_collections/hetzner/hcloud/Makefile
@@ -1,5 +1,8 @@
SHELL := bash
-.PHONY: vendor clean
+.PHONY: vendor clean dev
+
+dev:
+ cat tests/integration/cloud-config-hcloud.ini.in | envsubst > tests/integration/cloud-config-hcloud.ini
vendor:
python3 scripts/vendor.py
@@ -21,8 +24,7 @@ lint-docs: venv
.
clean:
- git clean -xdf \
- -e tests/integration/cloud-config-hcloud.ini
+ git clean -xdf
sanity:
ansible-test sanity --color --truncate 0 -v \