summaryrefslogtreecommitdiffstats
path: root/ansible_collections/containers/podman/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ansible_collections/containers/podman/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/ansible_collections/containers/podman/Makefile b/ansible_collections/containers/podman/Makefile
new file mode 100644
index 000000000..7dbdd9a6b
--- /dev/null
+++ b/ansible_collections/containers/podman/Makefile
@@ -0,0 +1,15 @@
+PKG_NAME=ansible-podman-collections
+TMPINSTALLDIR=/tmp/$(PKG_NAME)-fpm-install
+VERSION ?= $(shell python3 setup.py --version 2>/dev/null | sed "s/\([0-9]\+\.[0-9]\+\.[0-9]\+\).*/\1/g")
+
+rpm:
+ rm -rf $(TMPINSTALLDIR)
+ mkdir -p ~/rpmbuild/SOURCES/
+ mkdir -p $(TMPINSTALLDIR)/$(PKG_NAME)-$(VERSION)
+ cp -r * $(TMPINSTALLDIR)/$(PKG_NAME)-$(VERSION)/
+ tar -zcvf ~/rpmbuild/SOURCES/$(VERSION).tar.gz -C $(TMPINSTALLDIR) $(PKG_NAME)-$(VERSION)
+ cp ansible-collection-containers-podman.spec ansible-collection-containers-podman-build.spec
+ sed -i "s/Version:.*/Version: $(VERSION)/g" ansible-collection-containers-podman-build.spec
+ sed -i "s/Release:.*/Release: 999%{?dist}/g" ansible-collection-containers-podman-build.spec
+ sed -i "s/^version: .*/version: $(VERSION)/" $(TMPINSTALLDIR)/$(PKG_NAME)-$(VERSION)/galaxy.yml
+ rpmbuild -bb ansible-collection-containers-podman-build.spec