summaryrefslogtreecommitdiffstats
path: root/ansible_collections/hetzner/hcloud/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ansible_collections/hetzner/hcloud/Makefile')
-rw-r--r--ansible_collections/hetzner/hcloud/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/ansible_collections/hetzner/hcloud/Makefile b/ansible_collections/hetzner/hcloud/Makefile
index 48c411d64..12a2521ea 100644
--- a/ansible_collections/hetzner/hcloud/Makefile
+++ b/ansible_collections/hetzner/hcloud/Makefile
@@ -1,5 +1,8 @@
SHELL := bash
-.PHONY: vendor clean
+.PHONY: vendor clean dev
+
+dev:
+ cat tests/integration/cloud-config-hcloud.ini.in | envsubst > tests/integration/cloud-config-hcloud.ini
vendor:
python3 scripts/vendor.py
@@ -21,8 +24,7 @@ lint-docs: venv
.
clean:
- git clean -xdf \
- -e tests/integration/cloud-config-hcloud.ini
+ git clean -xdf
sanity:
ansible-test sanity --color --truncate 0 -v \