summaryrefslogtreecommitdiffstats
path: root/debian/patches/hurd_shm_flock.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/hurd_shm_flock.patch')
-rw-r--r--debian/patches/hurd_shm_flock.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/debian/patches/hurd_shm_flock.patch b/debian/patches/hurd_shm_flock.patch
new file mode 100644
index 0000000..5f1919f
--- /dev/null
+++ b/debian/patches/hurd_shm_flock.patch
@@ -0,0 +1,53 @@
+From: Pino Toscano <pino@debian.org>
+Bug: #656880
+
+# * hurd_shm_flock.diff
+# This patch disables all the methods for shared memory and file locking
+# found by the configure checks, forcing the only working ones.
+# This patch should stay Debian-specific, as it is not that suitable for
+# upstream inclusion. (As you can guess, ideally all of those
+# non-working methods should be ideally fixed in Hurd...)
+
+--- apr.orig/configure.in
++++ apr/configure.in
+@@ -1375,6 +1375,13 @@ case $host in
+ APR_DECISION_OVERRIDE(USE_SHMEM_SHMGET_ANON)
+ ;;
+ esac
++case $host_os in
++ gnu* )
++ haveshmgetanon="0"
++ havemmapanon="0"
++ APR_DECISION_OVERRIDE(USE_SHMEM_MMAP_ZERO)
++ ;;
++esac
+ APR_END_DECISION
+ AC_DEFINE_UNQUOTED($ac_decision)
+
+@@ -1452,6 +1459,13 @@ case $host in
+ APR_DECISION_OVERRIDE(USE_SHMEM_SHMGET)
+ ;;
+ esac
++case $host_os in
++ gnu* )
++ havemmapshm="0"
++ haveshmget="0"
++ APR_DECISION_OVERRIDE(USE_SHMEM_MMAP_TMP)
++ ;;
++esac
+ APR_END_DECISION
+ AC_DEFINE_UNQUOTED($ac_decision)
+
+@@ -2511,6 +2525,12 @@ esac
+ if test "x$apr_lock_method" != "x"; then
+ APR_DECISION_FORCE($apr_lock_method)
+ fi
++case $host_os in
++ gnu* )
++ hasfcntlser="0"
++ APR_DECISION_OVERRIDE(USE_FLOCK_SERIALIZE)
++ ;;
++esac
+ APR_END_DECISION
+ AC_DEFINE_UNQUOTED($ac_decision)
+