summaryrefslogtreecommitdiffstats
path: root/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 10:16:57 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 10:16:57 +0000
commit5fbfcdad1efbea3ce6580c682d813daa79c3653a (patch)
tree8a1d7c6b9c1bed457a7ee50b5919da8b9852b8f9 /methods/CMakeLists.txt
parentAdding upstream version 2.7.13. (diff)
downloadapt-5fbfcdad1efbea3ce6580c682d813daa79c3653a.tar.xz
apt-5fbfcdad1efbea3ce6580c682d813daa79c3653a.zip
Adding upstream version 2.7.14.upstream/2.7.14
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'methods/CMakeLists.txt')
-rw-r--r--methods/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/methods/CMakeLists.txt b/methods/CMakeLists.txt
index a5a3602..a94cb41 100644
--- a/methods/CMakeLists.txt
+++ b/methods/CMakeLists.txt
@@ -15,13 +15,15 @@ add_executable(ftp ftp.cc $<TARGET_OBJECTS:connectlib>)
add_executable(rred rred.cc)
add_executable(rsh rsh.cc)
-target_compile_definitions(connectlib PRIVATE ${GNUTLS_DEFINITIONS})
-target_include_directories(connectlib PRIVATE ${GNUTLS_INCLUDE_DIR})
+if (HAVE_GNUTLS)
+ target_compile_definitions(connectlib PRIVATE ${GNUTLS_DEFINITIONS})
+ target_include_directories(connectlib PRIVATE ${GNUTLS_INCLUDE_DIR})
+endif()
target_include_directories(http PRIVATE $<$<BOOL:${SYSTEMD_FOUND}>:${SYSTEMD_INCLUDE_DIRS}>)
# Additional libraries to link against for networked stuff
-target_link_libraries(http ${GNUTLS_LIBRARIES} $<$<BOOL:${SYSTEMD_FOUND}>:${SYSTEMD_LIBRARIES}>)
-target_link_libraries(ftp ${GNUTLS_LIBRARIES})
+target_link_libraries(http $<$<BOOL:${GNUTLS_FOUND}>:${GNUTLS_LIBRARIES}> $<$<BOOL:${SYSTEMD_FOUND}>:${SYSTEMD_LIBRARIES}>)
+target_link_libraries(ftp $<$<BOOL:${GNUTLS_FOUND}>:${GNUTLS_LIBRARIES}>)
target_link_libraries(rred apt-private)